summaryrefslogtreecommitdiff
path: root/dev-python/nose
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/Manifest3
-rw-r--r--dev-python/nose/metadata.xml13
-rw-r--r--dev-python/nose/nose-1.3.7_p20221026.ebuild58
3 files changed, 0 insertions, 74 deletions
diff --git a/dev-python/nose/Manifest b/dev-python/nose/Manifest
deleted file mode 100644
index ea375594e134..000000000000
--- a/dev-python/nose/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST nose-1.3.7_p20221026.gh.tar.gz 325421 BLAKE2B 3762e1703a6a9c90d1569d21efa9ba100f52a8b3660022694133a763d995e19a6eef2398f5013b4827e4c334a2d5e3cd14a9704a50cd822c2d554a0ed6008f2c SHA512 3cb97b58525bee0cf88328ba865dc039bf3b76c56b4b42dd9dcf68f7b7585a91fb7e9b0c419668eccc0e242b2bcbb77eb197a0954ee9ad50051ef3af1a81dac3
-EBUILD nose-1.3.7_p20221026.ebuild 1440 BLAKE2B ecc84c466335cd0ad1c1509d9889f63877152611701c21bef5d91613f0d5bb35b9ac28b9947ae2d72730691b149335fda5a78da970ec2b31172407af308710d2 SHA512 c9974fb71e2a2c8843902a42542bf89f395ef0b1e2f8ab03584d1b32709a9ef9b4979fc2aacdc5b4d81d2432ffb56415e5e2ec5a7f72deef22ef7ff595fa1ecd
-MISC metadata.xml 399 BLAKE2B bccd250e005dc4b4921b8affffa56c918069576663c44671189d40dea344c0fb880fcf41656b1c9c5043cea9a0203b3ad3b980f7920ecebab82b4c71f75214d4 SHA512 15fd9ea9d0c09833f25497e2715a15cb2b2dbcbe042e0a3fa24525455eaeb470d6c799fddcd635a5197c984252649a26352713fcd069123fe2546edc20566fa6
diff --git a/dev-python/nose/metadata.xml b/dev-python/nose/metadata.xml
deleted file mode 100644
index 554766d8e7d1..000000000000
--- a/dev-python/nose/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <stabilize-allarches/>
- <upstream>
- <remote-id type="pypi">nose</remote-id>
- <remote-id type="github">nose-devs/nose</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/nose/nose-1.3.7_p20221026.ebuild b/dev-python/nose/nose-1.3.7_p20221026.ebuild
deleted file mode 100644
index de12a5102c63..000000000000
--- a/dev-python/nose/nose-1.3.7_p20221026.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-EGIT_COMMIT="8def1b4dcf2ef6b4a34bffdfacea0018a78b06b6"
-DESCRIPTION="Unittest extension with automatic test suite discovery and easy test authoring"
-HOMEPAGE="
- https://pypi.org/project/nose/
- https://nose.readthedocs.io/en/latest/
- https://github.com/nose-devs/nose
-"
-SRC_URI="
- https://github.com/arthurzam/nose/archive/${EGIT_COMMIT}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- !hppa? ( dev-python/coverage[${PYTHON_USEDEP}] )
- ' python3_{8..10} pypy3)
- $(python_gen_cond_dep '
- dev-python/twisted[${PYTHON_USEDEP}]
- ' python3_{8..10})
- )
-"
-
-src_prepare() {
- # failing to find configuration file
- sed -e 's/test_cover_options_config_file/_&/' \
- -i unit_tests/test_cover_plugin.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- "${EPYTHON}" -m nose -v -a "!network" ||
- die "Tests fail with ${EPYTHON}"
-}
-
-src_install() {
- distutils-r1_src_install
- use examples && dodoc -r examples
-}