summaryrefslogtreecommitdiff
path: root/dev-python/nose-exclude/nose-exclude-0.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nose-exclude/nose-exclude-0.4.1.ebuild')
-rw-r--r--dev-python/nose-exclude/nose-exclude-0.4.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/nose-exclude/nose-exclude-0.4.1.ebuild b/dev-python/nose-exclude/nose-exclude-0.4.1.ebuild
new file mode 100644
index 000000000000..8c5d9a608e75
--- /dev/null
+++ b/dev-python/nose-exclude/nose-exclude-0.4.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Exclude specific directories from nosetests runs"
+HOMEPAGE="https://github.com/kgrandis/nose-exclude"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 s390 sparc x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}