summaryrefslogtreecommitdiff
path: root/dev-python/nbformat/nbformat-5.9.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nbformat/nbformat-5.9.2.ebuild')
-rw-r--r--dev-python/nbformat/nbformat-5.9.2.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/nbformat/nbformat-5.9.2.ebuild b/dev-python/nbformat/nbformat-5.9.2.ebuild
deleted file mode 100644
index 5f5380971b2c..000000000000
--- a/dev-python/nbformat/nbformat-5.9.2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-PYTHON_REQ_USE='sqlite'
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Reference implementation of the Jupyter Notebook format"
-HOMEPAGE="
- https://jupyter.org/
- https://github.com/jupyter/nbformat/
- https://pypi.org/project/nbformat/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/fastjsonschema[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-2.6[${PYTHON_USEDEP}]
- >=dev-python/traitlets-5.1[${PYTHON_USEDEP}]
- dev-python/jupyter-core[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/testpath[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs \
- dev-python/numpydoc \
- dev-python/myst-parser \
- dev-python/pydata-sphinx-theme
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}/nbformat-5.7.1-no-node.patch"
-)
-
-EPYTEST_IGNORE=(
- # requires pep440 package, which is not really relevant for us
- tests/test_api.py
-)