summaryrefslogtreecommitdiff
path: root/dev-python/nbclient/nbclient-0.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nbclient/nbclient-0.9.1.ebuild')
-rw-r--r--dev-python/nbclient/nbclient-0.9.1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/nbclient/nbclient-0.9.1.ebuild b/dev-python/nbclient/nbclient-0.9.1.ebuild
deleted file mode 100644
index 4a6655346995..000000000000
--- a/dev-python/nbclient/nbclient-0.9.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A client library for executing Jupyter notebooks"
-HOMEPAGE="
- https://nbclient.readthedocs.io/en/latest/
- https://github.com/jupyter/nbclient/
- https://pypi.org/project/nbclient/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/jupyter-client-6.1.12[${PYTHON_USEDEP}]
- >=dev-python/jupyter-core-5.1.0[${PYTHON_USEDEP}]
- >=dev-python/nbformat-5.0[${PYTHON_USEDEP}]
- >=dev-python/traitlets-5.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- >=dev-python/ipykernel-6.19.3[${PYTHON_USEDEP}]
- dev-python/ipywidgets[${PYTHON_USEDEP}]
- dev-python/nbconvert[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/testpath[${PYTHON_USEDEP}]
- dev-python/xmltodict[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_XDIST=1
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # hangs?
- 'tests/test_client.py::test_run_all_notebooks[Interrupt.ipynb-opts6]'
-)