summaryrefslogtreecommitdiff
path: root/dev-python/nbclient/nbclient-0.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nbclient/nbclient-0.8.0.ebuild')
-rw-r--r--dev-python/nbclient/nbclient-0.8.0.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/nbclient/nbclient-0.8.0.ebuild b/dev-python/nbclient/nbclient-0.8.0.ebuild
deleted file mode 100644
index 117030c6027b..000000000000
--- a/dev-python/nbclient/nbclient-0.8.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="A client library for executing Jupyter notebooks"
-HOMEPAGE="
- https://nbclient.readthedocs.io/en/latest/
- https://github.com/jupyter/nbclient/
- https://pypi.org/project/nbclient/
-"
-SRC_URI="
- https://github.com/jupyter/nbclient/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/jupyter-client-6.1.12[${PYTHON_USEDEP}]
- >=dev-python/jupyter-core-5.1.0[${PYTHON_USEDEP}]
- >=dev-python/nbformat-5.0[${PYTHON_USEDEP}]
- >=dev-python/traitlets-5.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- >=dev-python/ipykernel-6.19.3[${PYTHON_USEDEP}]
- dev-python/ipywidgets[${PYTHON_USEDEP}]
- dev-python/nbconvert[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/testpath[${PYTHON_USEDEP}]
- dev-python/xmltodict[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- nbclient/tests/test_client.py::test_many_parallel_notebooks
- 'nbclient/tests/test_client.py::test_run_all_notebooks[Interrupt.ipynb-opts6]'
-)
-
-python_test() {
- # The tests run the pydevd debugger, the debugger prints a warning
- # in python3.11 when frozen modules are being used.
- # This warning makes the tests fail, silence it.
- PYDEVD_DISABLE_FILE_VALIDATION=1 epytest
-}