summaryrefslogtreecommitdiff
path: root/dev-python/nbclassic
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nbclassic')
-rw-r--r--dev-python/nbclassic/Manifest4
-rw-r--r--dev-python/nbclassic/nbclassic-1.1.0-r1.ebuild (renamed from dev-python/nbclassic/nbclassic-1.0.0-r1.ebuild)24
2 files changed, 10 insertions, 18 deletions
diff --git a/dev-python/nbclassic/Manifest b/dev-python/nbclassic/Manifest
index ebb28577bf7d..0e25d0d4d86a 100644
--- a/dev-python/nbclassic/Manifest
+++ b/dev-python/nbclassic/Manifest
@@ -1,3 +1,3 @@
-DIST nbclassic-1.0.0.tar.gz 20201455 BLAKE2B 8d87668cdf2347c6d9dcc7f335d9bf346c1622217b71c18a91f7703f90ab5d2c71830f9743d6b408033ab153fe7180a9f07edc016704b9d0469bbf15c1641ef8 SHA512 fc80cd6311ab9cac9e0fdcf4d37cffc383c90327da8c27901239b84486e4afe23372665b0e1464ec78845816e829c4f3cf8672b4a0ad7e396fdb962b2f4f5a1b
-EBUILD nbclassic-1.0.0-r1.ebuild 2121 BLAKE2B 094c553bf3150dcc4cdd4e933b46786afa16ad6fb728c0f52b93ddafd64bfb9df0a8103ac68061b21e9310291f748d50007d15e071ad927cec12f389243f0a8b SHA512 a76e843d5c858afdcfeaef4fe245b6ebf35d65aff5982ba18ae01d18aa114a44c50125946574465b74ccc6cd589f3cd71e448d88e9b368c69ff747671866ced3
+DIST nbclassic-1.1.0.tar.gz 20194834 BLAKE2B 7fe5e3d405964faf09a6f58b54d03dae7ec661e276d5e26e71e054b277f99db61dd7ef0c3ec2417230ea7d724814a4919514b4274772b5a73a89d0c59db09468 SHA512 a5348ff7bff944c12745111fcf64ca92d75bf7bc063d51baf04bc8894473ba0689ec4420ff1ce2d2a40601b55d14a1cd257215cd4f11839fa47e8ea93933268d
+EBUILD nbclassic-1.1.0-r1.ebuild 1687 BLAKE2B 8b215aff17c3ba89cf6c495a553eb7391a0bddb615b05bdaf2abcfe3666f6c308614b64059e294d71abea17493296ec1fe67221ce74ac7200948a762d778f99e SHA512 c8b7e1250a49ad516a6e93d4b61e66af26895def5d9dc1e49e52a2cc023a34ea42be9e32e0afb64db169d899a2051108e6e9c9f39a42ba656473bca6cd33fb12
MISC metadata.xml 407 BLAKE2B 8be751d3f2e0e1e2952c39cd1846285ebb994d833022767dde609294ee9f98044b1189934e7d27c3134b1f06c95705687491dbf52739bdd0bc17f06cfdff53cf SHA512 6cc07376da4e55e5df153fdb0f43371ed415bed6db1bce2f67dd113d1e0f1994974dd6bee746021efb2d8c36ca2ca534109227c541d38b37b652a68b9642f2cb
diff --git a/dev-python/nbclassic/nbclassic-1.0.0-r1.ebuild b/dev-python/nbclassic/nbclassic-1.1.0-r1.ebuild
index 66fe16976f2b..2fcccb91bb51 100644
--- a/dev-python/nbclassic/nbclassic-1.0.0-r1.ebuild
+++ b/dev-python/nbclassic/nbclassic-1.1.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
DISTUTILS_USE_PEP517=jupyter
inherit distutils-r1 pypi xdg-utils
@@ -20,27 +20,15 @@ SLOT="0"
KEYWORDS="amd64 arm arm64 ~loong ppc64 ~riscv x86"
RDEPEND="
- dev-python/argon2-cffi[${PYTHON_USEDEP}]
dev-python/ipykernel[${PYTHON_USEDEP}]
dev-python/ipython_genutils[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- >=dev-python/jupyter-client-6.1.1[${PYTHON_USEDEP}]
- >=dev-python/jupyter-core-4.6.1[${PYTHON_USEDEP}]
- >=dev-python/nbconvert-5[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
>=dev-python/nest-asyncio-1.5[${PYTHON_USEDEP}]
>=dev-python/notebook-shim-0.2.3[${PYTHON_USEDEP}]
- dev-python/prometheus-client[${PYTHON_USEDEP}]
- >=dev-python/send2trash-1.8.0[${PYTHON_USEDEP}]
- >=dev-python/terminado-0.8.3[${PYTHON_USEDEP}]
- >=dev-python/tornado-6.1[${PYTHON_USEDEP}]
- >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
"
-# dev-python/nbval is missing impls
BDEPEND="
test? (
- dev-python/jupyter-server-terminals[${PYTHON_USEDEP}]
+ dev-python/nbval[${PYTHON_USEDEP}]
dev-python/pytest-jupyter[${PYTHON_USEDEP}]
dev-python/pytest-tornasync[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
@@ -54,7 +42,7 @@ BDEPEND="
distutils_enable_tests pytest
distutils_enable_sphinx docs/source \
- dev-python/sphinx-rtd-theme \
+ dev-python/pydata-sphinx-theme \
dev-python/nbsphinx \
dev-python/sphinxcontrib-github-alt \
dev-python/myst-parser \
@@ -62,6 +50,10 @@ distutils_enable_sphinx docs/source \
python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+
+ # Notebook interferes with our tests, pretend it does not exist
+ echo "raise ImportError" > notebook.py || die
+
epytest -p pytest_tornasync.plugin
}