summaryrefslogtreecommitdiff
path: root/dev-python/mypy_extensions/mypy_extensions-0.4.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mypy_extensions/mypy_extensions-0.4.3-r2.ebuild')
-rw-r--r--dev-python/mypy_extensions/mypy_extensions-0.4.3-r2.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-python/mypy_extensions/mypy_extensions-0.4.3-r2.ebuild b/dev-python/mypy_extensions/mypy_extensions-0.4.3-r2.ebuild
deleted file mode 100644
index 53bc5655473f..000000000000
--- a/dev-python/mypy_extensions/mypy_extensions-0.4.3-r2.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
-
-DESCRIPTION="Optional static typing for Python"
-HOMEPAGE="
- http://www.mypy-lang.org/
- https://github.com/python/mypy_extensions/"
-SRC_URI="
- https://github.com/python/mypy_extensions/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # This test assumes we get a TypeError, but that is no longer true in 3.11
- "tests/testextensions.py::TypedDictTests::test_typeddict_errors"
-)
-
-python_test() {
- epytest tests/*
-}