summaryrefslogtreecommitdiff
path: root/dev-python/mypy
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mypy')
-rw-r--r--dev-python/mypy/Manifest2
-rw-r--r--dev-python/mypy/mypy-1.5.0.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/mypy/Manifest b/dev-python/mypy/Manifest
index 85b10523e02a..146d818d09d0 100644
--- a/dev-python/mypy/Manifest
+++ b/dev-python/mypy/Manifest
@@ -1,5 +1,7 @@
DIST mypy-1.3.0.gh.tar.gz 2823529 BLAKE2B 0f1b4b6178ef9308fa6aeda494092229ebe07095c032b83fffd28be851608a3dc92ae4924ea64d87318155bf9d99bf16e17e2603f39fc915463455db520d6138 SHA512 1ab0e667bd019ea6804c70c775c2bfb454231ca2426b2b78b5c91672f7f20fd1195ee481a688d9b6238c3b5f6dc9a7aa5466c7405ce71dd6f78c489a43670fc0
DIST mypy-1.4.1.gh.tar.gz 2864808 BLAKE2B 7dfda945cf554e170d048fc4b2689aa25a57e058857e17dd052090089a7880da74a3dd552fb1b8f8fa9bd9e84f1c97e49b36075d10957c6ee12c2507fb775668 SHA512 8a20ded76d9d3f323dc607c6cfdd4814c2ab798620a0b38198c7ff79bd1fb93aef7f8d60afa6e568957fcd8d9bfdf42308da07b4b0dd6260f192131377ee6951
+DIST mypy-1.5.0.gh.tar.gz 2901221 BLAKE2B c23e0a5a5fc91a107fd11c9b0d97b0c19c671eb3aec718f216e53074bb4cdca96884611cdfdefd91189b9860ad54d84fecb468448f2819f4432f93594b2ffbae SHA512 2b82be7948d44ef8ec6592fc5756dee66df1ee363e2607796f69f76e3db96e421dab8ba2aea4db9e976f2b05314d97a031f1d197633df34a5667f4d1dabbd70f
EBUILD mypy-1.3.0-r1.ebuild 1786 BLAKE2B f76278013b9c7621bdaa795ff292ff53f93dcb8932dcd57c90ef5f7bd4059f8b880243a420675b868de79defd877df56631d701ce56d8d4b418dd75cf8a49607 SHA512 ce94cfbce9793beccffee975a10825bf0656613c2aace65a4e38babc663d79e1894250d191f07e27d39ce030591abc3e969b2d6e2ca761251f8b9a6320d1a83f
EBUILD mypy-1.4.1-r1.ebuild 1723 BLAKE2B b6658b287adec0c687e0120127adb2d475fa65cb04f8e8a8426f1ec1d22da9b515103b3770c6f54bdbd0fa24e8c4ec4b4fe9350399e8103c14f662f69f82fd9a SHA512 c12d21d700aa5770e592ceaba55bf5a664df991b41701af6605aa88483c44d63cf5bcec1c31a87fc553aebb9794f60c184bffa5806fb74520f45cd9e3cc270bc
+EBUILD mypy-1.5.0.ebuild 1684 BLAKE2B a2bd3071b225a4d34c7768fadfe6ef35df2b12ef06f66d565310b968832e4544e48e7d7862e4ef614cc433b90d5689c4dc01bef54def2fe0de8c5fab2c2f1087 SHA512 f5fb9f61e6a4ac6cdda6d5b9b0d5deebc9d38f136af8e50dbf8c7303f931af9d8ec01c315ad672435dadb58cb9977c23580310297cd6b80f56124a92173ce8c8
MISC metadata.xml 515 BLAKE2B 75827bbbeb70fd4b9295ab4689068d2d4b686b32d4059acde94fb0d08048e9e56ecaf3eec39dc5567b2753e2552353e273cdf2f4e27d077cc9b03320ee09c64b SHA512 c1c3c7a3651e61e0b63ab4462f0370cce9cbdce33e64c5e7a1fbefe8116d5d3d3b35bc4095d8a5ce28caf69b0644af3f13c9a27b683f2f981e52f8bfe4ac8615
diff --git a/dev-python/mypy/mypy-1.5.0.ebuild b/dev-python/mypy/mypy-1.5.0.ebuild
new file mode 100644
index 000000000000..515523a5daef
--- /dev/null
+++ b/dev-python/mypy/mypy-1.5.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="
+ https://www.mypy-lang.org/
+ https://github.com/python/mypy/
+ https://pypi.org/project/mypy/
+"
+SRC_URI="
+ https://github.com/python/mypy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# stubgen collides with this package: https://bugs.gentoo.org/585594
+RDEPEND="
+ !dev-util/stubgen
+ >=dev-python/psutil-4[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.1.0[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-1.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+BDEPEND="
+ test? (
+ >=dev-python/attrs-18.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.18[${PYTHON_USEDEP}]
+ >=dev-python/py-1.5.2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+# this requires packaging a lot of type stubs
+export MYPY_USE_MYPYC=0
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # the majority of them require Internet (via pip)
+ mypy/test/testpep561.py
+ )
+ # Some mypy/test/testcmdline.py::PythonCmdlineSuite tests
+ # fail with high COLUMNS values
+ local -x COLUMNS=80
+ epytest -n "$(makeopts_jobs)" --dist=worksteal
+}