summaryrefslogtreecommitdiff
path: root/dev-python/msgpack
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/msgpack')
-rw-r--r--dev-python/msgpack/Manifest2
-rw-r--r--dev-python/msgpack/msgpack-1.1.0.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/msgpack/Manifest b/dev-python/msgpack/Manifest
index 7adb088130ad..e40d7978a9c3 100644
--- a/dev-python/msgpack/Manifest
+++ b/dev-python/msgpack/Manifest
@@ -1,5 +1,7 @@
DIST msgpack-1.0.7.tar.gz 166311 BLAKE2B 8ddf2acf6bf81498d981c3ec83cbdffde1b1611f8ac23d3377f3f1541e679eda288b40b949bd586ca24a7059da3a0f73fa797a661375135ec092f408521c8527 SHA512 0ebd36f45b73106a4272588b55d55e72b6b8441be652b16f63f5547ae7ff1bc517a6b4549ef999ee63deb2856354a71ef37fd8d8829e516232518b046cf589c5
DIST msgpack-1.0.8.tar.gz 167014 BLAKE2B 714b0355941104e791c5a3b8ee2bd4f40b11484631a3bde63e7c0bdbb925a603c4704b037ab437c2330dc0d2e466d41ccfd50c6a45ef798e5cd34a87e4e3863f SHA512 b739667d4384ba0e18a4e55de6033933822180eb5d28bd7f5ecd7e7da112a214f400740feb45de6f0873d12c8b062b1a8b9b9e5939c2961a8c9585f282645c5b
+DIST msgpack-1.1.0.tar.gz 167260 BLAKE2B fd6497ce248fabae481de41cb27bccf001e75425564f16caff9f5dceb52d82949481589a92635f4c25178f03002daf604073fc2bb07c8133e81a8ee2f1ccb7c4 SHA512 2af3a6ae9a68a0261bf1cbb5ca6925004b421241c445d17023976fe38738049458937a578828cdf3c1f2fd19dfbbcceb21762957bfd459d6862adb110cad3faa
EBUILD msgpack-1.0.7.ebuild 1138 BLAKE2B ecad25caf021421a794ffd2890c936990378cc79a0cc4343e74197d9858a5dbc6aaa965c545a631970e17b917c3cac5aa03a8f9b7b9215feae3e21c03b10bf9a SHA512 a2140edd022303c38c85c2d55fb72d5e84efef292e738139291dff606e05782ae16de8a1385f155e10895c4da73d8cec8e224e9cfe1b08cd9bab3da4504a75f7
EBUILD msgpack-1.0.8.ebuild 1142 BLAKE2B eea1725b385205f3b8ab8a57111ebe4404f9245d05f06eae0898fc3c9e97ad9ccf52a2c4606594392959d36db3beb21fb70bae595acaeeb1aa118b5289229fae SHA512 02785fbe0c85302c78fc4a53c5be887101c77ab12aa9760522033c10327ec39cc8d1162d6c518f8c2642cd6a96e62128c8a4eae8692c1498cac83c9f198ed85b
+EBUILD msgpack-1.1.0.ebuild 1309 BLAKE2B 54af89af7238c0de4c46d342bbd5963c5d9d1ba31e2fa1eafefd8b27e088491bf117bd2968f9c4a0d3b262dc06758df2f6e860e2bfc91185946d3820627ddb8d SHA512 d8e142c6de37f783ff33ddb4986595a747c5033f7087b70650edc29683103cfa835d7a71d9fd0d6688ed7e161b653846d19ad7008a96608459a96df51a214fa0
MISC metadata.xml 520 BLAKE2B 5facc8e5c11591c6010fe5eef4030e23502b890d15a896ada0c5625e63179887e13206f28695af92b358c56a9f9660767d8b4234c2c8b489cad41fec01af289d SHA512 a62502d0b2ec3da1b21297f4d4e5fee86c206c8d6a2c19d7bffe2a64b4a2fa990edb3ba07bbacccb59ed79efd23fa713a37b8adffa7f0cbc811fc0fa249d9b63
diff --git a/dev-python/msgpack/msgpack-1.1.0.ebuild b/dev-python/msgpack/msgpack-1.1.0.ebuild
new file mode 100644
index 000000000000..774c70c44923
--- /dev/null
+++ b/dev-python/msgpack/msgpack-1.1.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="MessagePack (de)serializer for Python"
+HOMEPAGE="
+ https://msgpack.org/
+ https://github.com/msgpack/msgpack-python/
+ https://pypi.org/project/msgpack/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="+native-extensions"
+
+# extension code is relying on CPython implementation details
+BDEPEND="
+ native-extensions? (
+ $(python_gen_cond_dep '
+ >=dev-python/cython-3.0.8[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Remove pre-generated cython files
+ rm msgpack/_cmsgpack.c || die
+
+ # native-extensions are always disabled on PyPy
+ # https://github.com/msgpack/msgpack-python/blob/main/setup.py#L76
+ if ! use native-extensions; then
+ export MSGPACK_PUREPYTHON=1
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ if [[ ${EPYTHON} == python* && ! -f msgpack/_cmsgpack.c ]] &&
+ use native-extensions
+ then
+ cython -v msgpack/_cmsgpack.pyx || die
+ fi
+}
+
+python_test() {
+ rm -rf msgpack || die
+ epytest
+}