summaryrefslogtreecommitdiff
path: root/dev-python/monotonic/monotonic-1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/monotonic/monotonic-1.3.ebuild')
-rw-r--r--dev-python/monotonic/monotonic-1.3.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/monotonic/monotonic-1.3.ebuild b/dev-python/monotonic/monotonic-1.3.ebuild
new file mode 100644
index 000000000000..6d0bea266bd6
--- /dev/null
+++ b/dev-python/monotonic/monotonic-1.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of time.monotonic() for Python 2 & < 3.3"
+HOMEPAGE="https://github.com/atdt/monotonic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""