summaryrefslogtreecommitdiff
path: root/dev-python/mkdocstrings-python
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mkdocstrings-python')
-rw-r--r--dev-python/mkdocstrings-python/Manifest2
-rw-r--r--dev-python/mkdocstrings-python/mkdocstrings-python-1.10.8.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings-python/Manifest b/dev-python/mkdocstrings-python/Manifest
index 9394a2b1ab26..77a8b2351c86 100644
--- a/dev-python/mkdocstrings-python/Manifest
+++ b/dev-python/mkdocstrings-python/Manifest
@@ -1,5 +1,7 @@
DIST mkdocstrings-python-1.10.5.gh.tar.gz 157091 BLAKE2B 1f0685fc8b04ea4e5f33e3e4ca9637d590bd45b5be85d856ea0f6693d3be2a7d215751b68f811ca73afec078ffa5cc1acf88ab1907bd9842c6e390eb14fd71c0 SHA512 0bc3b103a99add6d38621243d2a21339efd837fb3476feb13bc55afabcee481d45ea7b410f8d16312583f308ee9f36f387762cdd1ef1e9758ecdb5b1be9dcb9e
DIST mkdocstrings_python-1.10.7.tar.gz 161638 BLAKE2B f62bd6b8f04223ba3ae479b04928888770cad02f5a060fcd39e5f20ddf80d88ff267f9826644cf80704a10f2f98320d1a5784c5bada43e845c07ab9c8a2d0d05 SHA512 1df467957e138f7fa474c2799b1cf254994b11b75217d90ff9c8a1f2d4c72817ecab80724c9da84721dbbde52c7074833534cde0ce8f50de6aae09b6edb25e03
+DIST mkdocstrings_python-1.10.8.tar.gz 161724 BLAKE2B 1720bd166c8b924f3d024ffbdaa46383a68ddbb4db1aff6d588049272f8e34046ac7ae62a6d9739dca029794e42afa0415179c978874b6012ace4842978184de SHA512 da179fc31af4bc6dba62b050c26736b313859dac6b8c29c877126081d6bb228255be626af09a61ae2a5b449dd0a1a19d41b1313dc9d1fd10e001e16a423c485c
EBUILD mkdocstrings-python-1.10.5.ebuild 875 BLAKE2B f4f7f739e6db98e6c7d2d93b51a1d930e1b4d38def147c4a79b1aab258a9832dbe61aa0dcff31689725ad841a046a04d087fefa065a0fd6c06fac24597b3a27b SHA512 17e2411b703cb00e7febd4ada18463ae5781abefb1817046a78d72843bee41c879e392b4a4036cc40b42b51f67782cb3dd2810ef974ce939430443fcb56b3c5f
EBUILD mkdocstrings-python-1.10.7.ebuild 703 BLAKE2B 1e0c92aa98c552fffac45c9ed5ebf50b6b62bece6c038653f8aa001247ab9e7f12479ed301bb651637154d600a921105fbd3fc811b125279a375c1a2f864d18b SHA512 7417531e762238e4d93bf20522868a7db896a61dc9a0045a72844dc65709feaae6f1d05bbf9deff0b21fff5a0b2a34e528591198d6867e2df999c8b68b3914f1
+EBUILD mkdocstrings-python-1.10.8.ebuild 703 BLAKE2B ab257bdcdb68b4c9c0057e15389b9e6a0ffda0d8d8443702381b5cda6b7398bb8a377292440022deea64041cc231c4b55b43369507bd81584130d82dfcd965a7 SHA512 0002dbf69f4011ed69d43302d8bacf305b5b4aecf27b71b157a50e49892608238089e89ba8dd7ec3b341f6db0f4ef573c68180f8c3702d053df9846b85154419
MISC metadata.xml 406 BLAKE2B c453b318ec32906f8b4917e9fcf9e82e632b780435d6617195590757dc8e08505dd29a05e8009808a040460ae322048801077aca8b41c8e07d093c4177befd39 SHA512 c56a8b222d22b5e4e8f396a96abddba840c4288b01958e261e3eb554830e88f424d840b839b7f6180f2f64c74cde9e2e3e8c70cdbbb8d4cc84ac161007064059
diff --git a/dev-python/mkdocstrings-python/mkdocstrings-python-1.10.8.ebuild b/dev-python/mkdocstrings-python/mkdocstrings-python-1.10.8.ebuild
new file mode 100644
index 000000000000..ff02e7706d04
--- /dev/null
+++ b/dev-python/mkdocstrings-python/mkdocstrings-python-1.10.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python handler for dev-python/mkdocstrings"
+HOMEPAGE="
+ https://mkdocstrings.github.io/python/
+ https://github.com/mkdocstrings/python/
+ https://pypi.org/project/mkdocstrings-python/
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/griffe-0.49[${PYTHON_USEDEP}]
+ >=dev-python/mkdocstrings-0.25.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}