summaryrefslogtreecommitdiff
path: root/dev-python/mkdocs-git-authors-plugin
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mkdocs-git-authors-plugin')
-rw-r--r--dev-python/mkdocs-git-authors-plugin/Manifest2
-rw-r--r--dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.7.2.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/mkdocs-git-authors-plugin/Manifest b/dev-python/mkdocs-git-authors-plugin/Manifest
index 43d81f517a24..fe08c4bc5291 100644
--- a/dev-python/mkdocs-git-authors-plugin/Manifest
+++ b/dev-python/mkdocs-git-authors-plugin/Manifest
@@ -1,5 +1,7 @@
DIST mkdocs-git-authors-plugin-0.7.0.gh.tar.gz 28526 BLAKE2B 876b273b476d10f037053ac8c4892f9225b514bfedecd26a7a9dcfd067609c5458fa4c2ed741048092c88dfcda196eab035e4909d3a8184579971273401cbf7c SHA512 aa92a5b49c4f02ea1c4eb5242fc585a341f837e7ebb27a450d703a170fb5e2e9ea5b04e2c6f121747300d86ac5fc0e69a553e1d7b02786e8fd6cd4943cbec6c2
DIST mkdocs-git-authors-plugin-0.7.1.gh.tar.gz 28974 BLAKE2B aea1a6d844aaf4ecd9b94d5cb62bfb59206838f825a96431f123e2706eb44f371cb893e45f0b5311ad2a47403b3be0e896383b3be7ab92a5a4b45d873bbc1370 SHA512 0de4ab85de1b1803ef6410bbeffb7f4ae03b6ce5aa1d9c3926004144c037193765b4e1d02560960fd6954f2f887694345c19dcdeea17cabf6a51fcb0b7120243
+DIST mkdocs-git-authors-plugin-0.7.2.gh.tar.gz 29300 BLAKE2B a93e87cde212fe15c1986bfdeeef207637b1bb10de1f864b0014b6dc0c74a64dbe152eae33c176adbb0e148cebd15717a307f874fd218e638835ce0687de14d8 SHA512 6fdaa7d06f0f0326b4123be546f0ad78ee3769a0048528e866b5c787ccaad9ba33e9c47b3597eea5b43d91f949d07b5cae9eca167b12978c7f577314e55c2721
EBUILD mkdocs-git-authors-plugin-0.7.0.ebuild 1302 BLAKE2B 2a47c9f2e0c1a722bf20fd7843a4bfca5ae38ab95db20e3d1d2bfb6ec0481707128a33d8e523ffab6385d22f2b92e9f26bd044853d2e595f21e571822b422a4d SHA512 727ebf6e04e1f2b74bc7d3ed74e940a6c1684378ac3523a55269b515027d214f3ecee92787b100dbf9cfd1050cd8e6999c22ad448c593abdb9d614f4c716b537
EBUILD mkdocs-git-authors-plugin-0.7.1.ebuild 1305 BLAKE2B 3f3c45464ad08aaf91d12fbb38714392f5c11a2a334812d52d7dd0479b92372d714358dd33265efd7a986a85b9b43747c638f039fc38c77af3e44221f5b16bdc SHA512 d0ee3cfd85da964840afce249e69ef2a5a3b37b2aba3ec7f506cd7a9f89e514c06f47e214f0f2e682d4fc5675bc7aedfd05d4d17a0b511f655e5c1f6141c4c42
+EBUILD mkdocs-git-authors-plugin-0.7.2.ebuild 1305 BLAKE2B 3f3c45464ad08aaf91d12fbb38714392f5c11a2a334812d52d7dd0479b92372d714358dd33265efd7a986a85b9b43747c638f039fc38c77af3e44221f5b16bdc SHA512 d0ee3cfd85da964840afce249e69ef2a5a3b37b2aba3ec7f506cd7a9f89e514c06f47e214f0f2e682d4fc5675bc7aedfd05d4d17a0b511f655e5c1f6141c4c42
MISC metadata.xml 564 BLAKE2B cee03d6742cb66a51c92f8999483f6c04c2b3fc7e8b88f5882bbabc577a54e922bdccf8a1a467e601c43511a372ac90ff8aa4500bd95715cffa83214ee2e64e9 SHA512 2b5539fff2990ebd293715b659e7b9bdeb63117c35933f49a21b873b45188476d3d44f6ac5b1656ee598f028e80f648b91b36ef4dae3f900705dbe2a7355356e
diff --git a/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.7.2.ebuild b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.7.2.ebuild
new file mode 100644
index 000000000000..2c5e16a6a392
--- /dev/null
+++ b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.7.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..11} )
+
+# Requires self to be installed to build docs
+# TODO: Do this a bit better
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ dev-python/regex
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-authors-plugin
+"
+DOCS_INITIALIZE_GIT=1
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Mkdocs plugin to display git authors of a page"
+HOMEPAGE="
+ https://github.com/timvink/mkdocs-git-authors-plugin/
+ https://pypi.org/project/mkdocs-git-authors-plugin/
+"
+SRC_URI="https://github.com/timvink/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+# Tests are broken outside of upstream git repo
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ dev-python/mkdocs-git-revision-date-localized-plugin[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-authors tests need git repo
+ use test && initialize_git_repo
+
+ distutils-r1_python_prepare_all
+}