summaryrefslogtreecommitdiff
path: root/dev-python/misaka/misaka-2.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/misaka/misaka-2.1.1.ebuild')
-rw-r--r--dev-python/misaka/misaka-2.1.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/misaka/misaka-2.1.1.ebuild b/dev-python/misaka/misaka-2.1.1.ebuild
new file mode 100644
index 000000000000..f1a7a807f3cc
--- /dev/null
+++ b/dev-python/misaka/misaka-2.1.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A CFFI binding for Hoedown, a markdown parsing library"
+HOMEPAGE="http://misaka.61924.nl/ https://github.com/FSX/misaka"
+SRC_URI="https://github.com/FSX/misaka/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-python/cffi[${PYTHON_USEDEP}]"
+
+# FIXME: tests requires write access outside sandbox
+#distutils_enable_tests setup.py