summaryrefslogtreecommitdiff
path: root/dev-python/memory_profiler
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/memory_profiler')
-rw-r--r--dev-python/memory_profiler/Manifest4
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.58.0.ebuild55
-rw-r--r--dev-python/memory_profiler/metadata.xml3
3 files changed, 60 insertions, 2 deletions
diff --git a/dev-python/memory_profiler/Manifest b/dev-python/memory_profiler/Manifest
index b968cc9ec068..d445c44497eb 100644
--- a/dev-python/memory_profiler/Manifest
+++ b/dev-python/memory_profiler/Manifest
@@ -1,3 +1,5 @@
DIST memory_profiler-0.57.tar.gz 84096 BLAKE2B d2c5fe810b9ac2f1e52fb8630056ee825d3d56799c15a377bff914be3a04e11c872e557847ef2a107421d082515eb59906f931ad1873ae7fec58fef16caabb4c SHA512 c6e2f755656dc820dfc2cf7a659dc319b3d1aa0df144ac6a08db35f4b38a90a9b994cf9c8320b8370f51c97e0d0bf2f9c4a3ab070b4934879f8e579b732e426a
+DIST memory_profiler-0.58.0.gh.tar.gz 140692 BLAKE2B 2f3917d833dfcc722b61871c7e704e869527a389b10a81b473989b8455630f5defa5f5b21a172708070b89468c7dd66682cd3b9c0bf435e9be49651b69b50137 SHA512 5c02933acffc05f42d2ae98a069d36563e1d26515d439d94ad3903960dd06cd378faae3000b26c022770e71e83db6f770ceaf63cabb92f4159bda0ff9cc4e849
EBUILD memory_profiler-0.57.ebuild 1761 BLAKE2B 11620de24512de621dec0c7724653fa1e875781355abc083ea3c932be8c86b31391d6d60744a8f4351b4485b9402234895730de118ca47d60649dfe2495687ec SHA512 91df54c1f7ee42ce9c743f38683810337d32385e4f1ee944f0947d5c7573c01b9ba84a0ff59630020127231865d26d9f515a791170162d9231d3a3e7694a43ef
-MISC metadata.xml 514 BLAKE2B 9721c8c8ab0f05e50b0d3d9fe16e0392aaa513177abdd4318aa2b10c70a656627e054b0a162eb7324e9b20e8f74dd1c3f3fbf4aa456fe98a34899525e3d9ad5a SHA512 cedc4d8914ad8cf10c8981935089220967957ff50eecfd867376974055d4922df91357a2f2135ce3cf5f56a27c5111005ae53429e685f0ee080e031bb2a3e943
+EBUILD memory_profiler-0.58.0.ebuild 1753 BLAKE2B 84d8ca6a8b9e848da8470a1887b8f6c84274cf08e420515d25e3fadf463bf1c2cc9ccf00b6da3796d807273c5609495c776c5abb33a98a157247b9ef333ed46a SHA512 4443b1699eca0b0aa7da8b0042b0b67bccd128d1cd7c12b0f3f3b8c2a1de7808105a7d687a4a8776437895da13e38599b43d5499408badcf45563d56bf1e16da
+MISC metadata.xml 547 BLAKE2B aaace8b03c5729d5f3142bd36015199bab32b75ad34b66ed20f9a20059e8be753dfcdd48c6adbed32426ae2e7b32657f799b62c09eb9702d4df0f156c13f2f39 SHA512 f24dc6ae8e426e9be3d583ce2d30bc085d79e32729c6ec19bbc17b48f56dc176b4c5ae71ae03e2867f7637bc0176226f9a6101c165d3a07a11037ef79d24cb43
diff --git a/dev-python/memory_profiler/memory_profiler-0.58.0.ebuild b/dev-python/memory_profiler/memory_profiler-0.58.0.ebuild
new file mode 100644
index 000000000000..6103471407d7
--- /dev/null
+++ b/dev-python/memory_profiler/memory_profiler-0.58.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A module for monitoring memory usage of a python program"
+HOMEPAGE="https://pypi.org/project/memory_profiler/ https://github.com/pythonprofilers/memory_profiler"
+SRC_URI="
+ https://github.com/pythonprofilers/memory_profiler/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+IUSE="examples"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+# dev-lang/mercury: collision on 'mprof'
+# https://bugs.gentoo.org/571176
+RDEPEND="dev-python/psutil[${PYTHON_USEDEP}]
+ !dev-lang/mercury"
+
+distutils_enable_tests pytest
+
+python_test() {
+ ${EPYTHON} -m memory_profiler test/test_as.py || die
+ ${EPYTHON} -m memory_profiler test/test_func.py || die
+ ${EPYTHON} -m memory_profiler test/test_gen.py || die
+ ${EPYTHON} -m memory_profiler test/test_loop.py || die
+ ${EPYTHON} -m memory_profiler test/test_loop_decorated.py || die
+ ${EPYTHON} -m memory_profiler test/test_mprofile.py || die
+ ${EPYTHON} -m memory_profiler test/test_nested.py || die
+ ${EPYTHON} -m memory_profiler test/test_precision_command_line.py || die
+ ${EPYTHON} -m memory_profiler test/test_unicode.py || die
+
+ ${EPYTHON} test/test_exception.py || die
+ ${EPYTHON} test/test_exit_code.py || die
+ ${EPYTHON} test/test_global.py || die
+ ${EPYTHON} test/test_import.py || die
+ ${EPYTHON} test/test_memory_usage.py || die
+ ${EPYTHON} test/test_mprof.py || die
+ ${EPYTHON} test/test_precision_import.py || die
+ ${EPYTHON} test/test_stream_unicode.py || die
+ ${EPYTHON} test/test_tracemalloc.py || die
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/memory_profiler/metadata.xml b/dev-python/memory_profiler/metadata.xml
index 73a90c01eacf..c59e1ac0dfd8 100644
--- a/dev-python/memory_profiler/metadata.xml
+++ b/dev-python/memory_profiler/metadata.xml
@@ -5,12 +5,13 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">memory_profiler</remote-id>
+ <remote-id type="github">pythonprofilers/memory_profiler</remote-id>
<maintainer status="unknown">
<email>f@bianp.net</email>
<name>Fabian Pedregosa</name>
</maintainer>
- <remote-id type="github">fabianp/memory_profiler</remote-id>
</upstream>
</pkgmetadata>