summaryrefslogtreecommitdiff
path: root/dev-python/meld3/meld3-1.0.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/meld3/meld3-1.0.2-r2.ebuild')
-rw-r--r--dev-python/meld3/meld3-1.0.2-r2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/meld3/meld3-1.0.2-r2.ebuild b/dev-python/meld3/meld3-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..7fa57a127022
--- /dev/null
+++ b/dev-python/meld3/meld3-1.0.2-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="meld3 is an HTML/XML templating engine"
+HOMEPAGE="https://github.com/supervisor/meld3 https://pypi.org/project/meld3/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}