summaryrefslogtreecommitdiff
path: root/dev-python/matplotlib/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/matplotlib/files')
-rw-r--r--dev-python/matplotlib/files/matplotlib-3.1.2-no-jqueryui-download.patch15
-rw-r--r--dev-python/matplotlib/files/matplotlib-3.1.2-qhull.patch20
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/matplotlib/files/matplotlib-3.1.2-no-jqueryui-download.patch b/dev-python/matplotlib/files/matplotlib-3.1.2-no-jqueryui-download.patch
new file mode 100644
index 000000000000..145f321039b9
--- /dev/null
+++ b/dev-python/matplotlib/files/matplotlib-3.1.2-no-jqueryui-download.patch
@@ -0,0 +1,15 @@
+Index: matplotlib-3.1.2/setup.py
+===================================================================
+--- matplotlib-3.1.2.orig/setup.py
++++ matplotlib-3.1.2/setup.py
+@@ -125,7 +125,9 @@ cmdclass['build_ext'] = BuildExtraLibrar
+
+
+ def _download_jquery_to(dest):
+- if os.path.exists(os.path.join(dest, "jquery-ui-1.12.1")):
++ # Avoid downloading jquery ui during emerge: we already have it in
++ # pypi's tarball. use this!
++ if True:
+ return
+
+ # If we are installing from an sdist, use the already downloaded jquery-ui
diff --git a/dev-python/matplotlib/files/matplotlib-3.1.2-qhull.patch b/dev-python/matplotlib/files/matplotlib-3.1.2-qhull.patch
new file mode 100644
index 000000000000..e02e03e65edb
--- /dev/null
+++ b/dev-python/matplotlib/files/matplotlib-3.1.2-qhull.patch
@@ -0,0 +1,20 @@
+Index: matplotlib-3.1.2/setupext.py
+===================================================================
+--- matplotlib-3.1.2.orig/setupext.py
++++ matplotlib-3.1.2/setupext.py
+@@ -839,14 +839,7 @@ class Qhull(SetupPackage):
+ name = "qhull"
+
+ def add_flags(self, ext):
+- # Qhull doesn't distribute pkg-config info, so we have no way of
+- # knowing whether a system install is recent enough. Thus, always use
+- # the vendored version.
+- ext.include_dirs.insert(0, 'extern')
+- ext.sources.extend(sorted(glob.glob('extern/libqhull/*.c')))
+- if sysconfig.get_config_var('LIBM') == '-lm':
+- ext.libraries.extend('m')
+-
++ ext.libraries.extend(['qhull'])
+
+ class TTConv(SetupPackage):
+ name = "ttconv"