summaryrefslogtreecommitdiff
path: root/dev-python/markups/markups-3.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/markups/markups-3.1.1.ebuild')
-rw-r--r--dev-python/markups/markups-3.1.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/markups/markups-3.1.1.ebuild b/dev-python/markups/markups-3.1.1.ebuild
new file mode 100644
index 000000000000..c18b011171b4
--- /dev/null
+++ b/dev-python/markups/markups-3.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+MY_P=${P^}
+
+DESCRIPTION="A wrapper around various text markups"
+HOMEPAGE="
+ https://pymarkups.readthedocs.io/en/latest/
+ https://github.com/retext-project/pymarkups
+ https://pypi.org/project/Markups/
+"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' python3_7 pypy3)
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/python-markdown-math[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ app-text/pytextile[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pymdown-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest