summaryrefslogtreecommitdiff
path: root/dev-python/mamba/mamba-0.11.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mamba/mamba-0.11.2.ebuild')
-rw-r--r--dev-python/mamba/mamba-0.11.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/mamba/mamba-0.11.2.ebuild b/dev-python/mamba/mamba-0.11.2.ebuild
new file mode 100644
index 000000000000..805822665e73
--- /dev/null
+++ b/dev-python/mamba/mamba-0.11.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python test runner born under the banner of Behavior Driven Development"
+HOMEPAGE="https://nestorsalceda.github.io/mamba"
+SRC_URI="https://github.com/nestorsalceda/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/clint-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ >=dev-python/doublex-expects-0.7.0_rc1[${PYTHON_USEDEP}]
+ >=dev-python/expects-0.8.0_rc2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs --no-autodoc
+
+python_test() {
+ "${EPYTHON}" -m mamba.cli || die "Tests failed under ${EPYTHON}"
+}