summaryrefslogtreecommitdiff
path: root/dev-python/makefun/makefun-1.15.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/makefun/makefun-1.15.2.ebuild')
-rw-r--r--dev-python/makefun/makefun-1.15.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/makefun/makefun-1.15.2.ebuild b/dev-python/makefun/makefun-1.15.2.ebuild
new file mode 100644
index 000000000000..b15e2249b8af
--- /dev/null
+++ b/dev-python/makefun/makefun-1.15.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Small library to dynamically create Python functions"
+HOMEPAGE="
+ https://pypi.org/project/makefun/
+ https://github.com/smarie/python-makefun/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/pytest-runner/d' -i setup.cfg || die
+ distutils-r1_src_prepare
+}