summaryrefslogtreecommitdiff
path: root/dev-python/m2crypto
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/m2crypto')
-rw-r--r--dev-python/m2crypto/Manifest2
-rw-r--r--dev-python/m2crypto/m2crypto-0.37.1.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/m2crypto/Manifest b/dev-python/m2crypto/Manifest
index 50b0380908c0..e6be9d0bf772 100644
--- a/dev-python/m2crypto/Manifest
+++ b/dev-python/m2crypto/Manifest
@@ -1,6 +1,8 @@
AUX m2crypto-libressl-0.31.0.patch 8211 BLAKE2B dc36c1e77f6fa9f260d465c0e61168a9ddd82f382c46f31c06a3ef5972cbbe225f665eac17999f7c8a0b74e1702f82451fed5a39691577b050f477bbf7a2ee2e SHA512 ea100feabae82cf1c1237f55354847935a9c49e05c780e01d8fef959d2a10abc4b9f14c56ea50cba68ff59eb67c3cf5136ff92e9dc456960327e0c582b55720d
DIST M2Crypto-0.35.2.tar.gz 1117706 BLAKE2B efa15e023be7755b94c642bb23eade912edcbbb76bcdfed3414d27937cd705ec4c83069ca620fe20e58e126549ba7f98e84f6f8330b78133a8a8b953d18f467b SHA512 3608b29a8e7d0732a2359e35fcaae191447aa7c0211ca3d057eed6cee7f0819f5c1121e7d41caca8cdea3c7911f8c447ee475b1b3d125e8dc3adde2718a59f36
DIST M2Crypto-0.36.0.tar.gz 1127584 BLAKE2B 5cdbbb11ff67d4ddffb2853a72383f3c7f1e1aa53ab84166aeda4fbea1b0d7f506761bb07bf8cb5b36f94bdbeb2ea2b46e0693da8355f81b4bf5c4c1c1cc18b1 SHA512 5b7d6d10c943ff0e09e0e9748d5578e7e0f7659a73de4ba49481152bca05871aef2bfbb869e1636a7cebcf2dd8b9f67fb0d299a833d1d4ebd538031c35d7bca1
+DIST M2Crypto-0.37.1.tar.gz 1247031 BLAKE2B 3628150b8da15d7356298b6e52e0d8fa7875921a184a0eba3a97eff0588c9e0fee340c92fd486919057d900d6e3b2b711174dde9761fe247848f92ac6434df0a SHA512 9a5e0220704b4897a9ca7efa4b3b57447b9175c52e8039a85bff7bb1a43b709c69f3c8b5903df461f8de39d3f8a20f9bf494df6f5882771846adfe2c03fbea9e
EBUILD m2crypto-0.35.2-r1.ebuild 1423 BLAKE2B 92478c705a27ff450272dcda5111f612fe0bc5c096d0059859d1e5b3ab349a70f8f39c150658fec1d2c02e7aaac1dff95f2af77b190c790d02b222187334a9ea SHA512 54dff1c9e7ee5320f6a4c6f527db81135af475425c70c71516fa96589cb8ea6dc6e43df3a6f46d325adeb15619ed71c448545ab1ad6fee8edb6f7401dc0830b5
EBUILD m2crypto-0.36.0-r1.ebuild 1553 BLAKE2B 0658aca2425aaffd659237def2152368c775ff72d94db787cdc687a6de90368445407267cdcb23db3e4d0dd323e556f7d2e5205f8d37827e0297384b2ebe758b SHA512 491c04ef3f8bef87a6e7be22af4a45e30ba726c97a46e4e2d17a344d930cda747e40a15517901389061e69131581cba039300552af4cffdaa5cbf3ca70b527ad
+EBUILD m2crypto-0.37.1.ebuild 1535 BLAKE2B 28a6c7f03d916220278f27330bfc737917e354711ee83d74af1725322bfb3c0ce5365460cf1fe3b16086024dab50d0180e583c60fad30224852748d1356d83cd SHA512 75f9c878ca42f19f6ffeb9720ed01983be399167e3a5f2684d166337bfed4c505014887f286068643b09d47eb1691a60c89e85d21040982d28be33b96dd1a020
MISC metadata.xml 380 BLAKE2B 99a1c8e8202bed7c6d0ff8cdff3f17b664791405b082be2b7d72b3fe2b77bf89c886666d9bdce6a96c540b9518042b9d49b9af926ca10ab4c5b3b416182de01c SHA512 f2e3b4228c45471f0132b3bb412f017f4006eb82bd63e187db3efdfd3f412c1db19bdb79d37630bb059f75ef69f110687b8924d22c2aef0101cb40eb3486f1e6
diff --git a/dev-python/m2crypto/m2crypto-0.37.1.ebuild b/dev-python/m2crypto/m2crypto-0.37.1.ebuild
new file mode 100644
index 000000000000..3b64631d0aa1
--- /dev/null
+++ b/dev-python/m2crypto/m2crypto-0.37.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 toolchain-funcs
+
+MY_PN="M2Crypto"
+DESCRIPTION="A Python crypto and SSL toolkit"
+HOMEPAGE="https://gitlab.com/m2crypto/m2crypto https://pypi.org/project/M2Crypto/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="libressl test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ >=dev-lang/swig-2.0.9
+ test? ( dev-python/parameterized[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-libressl-0.31.0.patch"
+)
+
+swig_define() {
+ local x
+ for x; do
+ if tc-cpp-is-true "defined(${x})"; then
+ SWIG_FEATURES+=" -D${x}"
+ fi
+ done
+}
+
+src_prepare() {
+ # TODO
+ sed -e 's:test_server_simple_timeouts:_&:' \
+ -i tests/test_ssl.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ # setup.py looks at platform.machine() to determine swig options.
+ # For exotic ABIs, we need to give swig a hint.
+ local -x SWIG_FEATURES=
+
+ # https://bugs.gentoo.org/617946
+ swig_define __ILP32__
+
+ # https://bugs.gentoo.org/674112
+ swig_define __ARM_PCS_VFP
+
+ distutils-r1_python_compile --openssl="${ESYSROOT}"/usr
+}
+
+python_test() {
+ esetup.py test
+}