summaryrefslogtreecommitdiff
path: root/dev-python/lz4/lz4-4.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lz4/lz4-4.3.2.ebuild')
-rw-r--r--dev-python/lz4/lz4-4.3.2.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/dev-python/lz4/lz4-4.3.2.ebuild b/dev-python/lz4/lz4-4.3.2.ebuild
index ef9a2537225b..08269ec71c17 100644
--- a/dev-python/lz4/lz4-4.3.2.ebuild
+++ b/dev-python/lz4/lz4-4.3.2.ebuild
@@ -33,10 +33,17 @@ BDEPEND="
)
"
+# note: test suite fails with xdist
distutils_enable_tests pytest
-EPYTEST_IGNORE=(
- # lz4.stream is not officially supported and not installed by default
- # (we do not support installing it at the moment)
- tests/stream
-)
+python_test() {
+ local EPYTEST_IGNORE=(
+ # lz4.stream is not officially supported and not installed by default
+ # (we do not support installing it at the moment)
+ tests/stream
+ )
+
+ rm -rf lz4 || die
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}