summaryrefslogtreecommitdiff
path: root/dev-python/loky/loky-2.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/loky/loky-2.9.0.ebuild')
-rw-r--r--dev-python/loky/loky-2.9.0.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/loky/loky-2.9.0.ebuild b/dev-python/loky/loky-2.9.0.ebuild
index 6a166599dde5..25edf84e76a1 100644
--- a/dev-python/loky/loky-2.9.0.ebuild
+++ b/dev-python/loky/loky-2.9.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Robust and reusable Executor for joblib"
@@ -27,6 +27,7 @@ distutils_enable_tests pytest
PATCHES=(
"${FILESDIR}"/${P}-libc.patch
+ "${FILESDIR}"/${P}-fix-py3.10-tests.patch
)
python_test() {
@@ -38,6 +39,8 @@ python_test() {
# one test that uses a lot of memory, also broken on 32-bit
# platforms
--skip-high-memory
+ # breaks teardown
+ -p no:xvfb
)
epytest "${args[@]}"