summaryrefslogtreecommitdiff
path: root/dev-python/logutils/logutils-0.3.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/logutils/logutils-0.3.5-r1.ebuild')
-rw-r--r--dev-python/logutils/logutils-0.3.5-r1.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/dev-python/logutils/logutils-0.3.5-r1.ebuild b/dev-python/logutils/logutils-0.3.5-r1.ebuild
index 78283ceaa872..5e075ff90665 100644
--- a/dev-python/logutils/logutils-0.3.5-r1.ebuild
+++ b/dev-python/logutils/logutils-0.3.5-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
@@ -16,4 +16,15 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
-distutils_enable_tests setup.py
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/redis-py[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -s tests
+}