summaryrefslogtreecommitdiff
path: root/dev-python/loguru/loguru-0.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/loguru/loguru-0.3.1.ebuild')
-rw-r--r--dev-python/loguru/loguru-0.3.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/loguru/loguru-0.3.1.ebuild b/dev-python/loguru/loguru-0.3.1.ebuild
new file mode 100644
index 000000000000..f3f34085887e
--- /dev/null
+++ b/dev-python/loguru/loguru-0.3.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python logging made (stupidly) simple"
+HOMEPAGE="https://github.com/Delgan/loguru"
+SRC_URI="https://github.com/Delgan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/colorama-0.3.4[${PYTHON_USEDEP}]"
+
+DEPEND="
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ >=dev-python/colorama-0.3.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.5.0[${PYTHON_USEDEP}]
+ )
+"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}