summaryrefslogtreecommitdiff
path: root/dev-python/lit/lit-5.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lit/lit-5.0.2.ebuild')
-rw-r--r--dev-python/lit/lit-5.0.2.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/lit/lit-5.0.2.ebuild b/dev-python/lit/lit-5.0.2.ebuild
deleted file mode 100644
index 3eebf5e676bc..000000000000
--- a/dev-python/lit/lit-5.0.2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
-inherit distutils-r1
-
-MY_P=llvm-${PV/_/}.src
-DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
-HOMEPAGE="https://llvm.org/"
-SRC_URI="https://releases.llvm.org/${PV/_//}/${MY_P}.tar.xz"
-
-LICENSE="UoI-NCSA"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ~ppc64 x86 ~amd64-fbsd"
-IUSE="test"
-
-S=${WORKDIR}/${MY_P}/utils/lit
-
-# Tests require 'FileCheck' and 'not' utilities (from llvm)
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/psutil[${PYTHON_USEDEP}]
- sys-devel/llvm )"
-
-# TODO: move the manpage generation here (from sys-devel/llvm)
-
-src_unpack() {
- einfo "Unpacking parts of ${MY_P}.tar.xz ..."
- tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/utils/lit" || die
-}
-
-python_test() {
- ./lit.py -sv tests || die
-}