summaryrefslogtreecommitdiff
path: root/dev-python/libtmux/libtmux-0.8.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/libtmux/libtmux-0.8.2.ebuild')
-rw-r--r--dev-python/libtmux/libtmux-0.8.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/libtmux/libtmux-0.8.2.ebuild b/dev-python/libtmux/libtmux-0.8.2.ebuild
new file mode 100644
index 000000000000..96e575bd8742
--- /dev/null
+++ b/dev-python/libtmux/libtmux-0.8.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="python api for tmux"
+HOMEPAGE="https://libtmux.git-pull.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${BDEPEND}
+ test? (
+ >=dev-python/pytest-4.5.0[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )"
+RDEPEND="app-misc/tmux"
+
+# tests aren't included in the dist tarball
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}