summaryrefslogtreecommitdiff
path: root/dev-python/libtmux/libtmux-0.10.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/libtmux/libtmux-0.10.3.ebuild')
-rw-r--r--dev-python/libtmux/libtmux-0.10.3.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/libtmux/libtmux-0.10.3.ebuild b/dev-python/libtmux/libtmux-0.10.3.ebuild
deleted file mode 100644
index 12b09f6f2d19..000000000000
--- a/dev-python/libtmux/libtmux-0.10.3.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-inherit distutils-r1
-
-DESCRIPTION="python api for tmux"
-HOMEPAGE="https://libtmux.git-pull.com/"
-SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${PN}-v${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-
-RDEPEND="
- >=app-misc/tmux-3.0a
-"
-BDEPEND="
- test? (
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/twine[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- local issues="https://github.com/tmux-python/libtmux/issues/"
- sed -r -i "s|:issue:\`([[:digit:]]+)\`|\`issue \1 ${issues}\1\`|" CHANGES || die
- rm requirements/doc.txt || die
-
- distutils-r1_python_prepare_all
-}