summaryrefslogtreecommitdiff
path: root/dev-python/libnacl/libnacl-1.7.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/libnacl/libnacl-1.7.2-r1.ebuild')
-rw-r--r--dev-python/libnacl/libnacl-1.7.2-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/libnacl/libnacl-1.7.2-r1.ebuild b/dev-python/libnacl/libnacl-1.7.2-r1.ebuild
new file mode 100644
index 000000000000..614f90975ef6
--- /dev/null
+++ b/dev-python/libnacl/libnacl-1.7.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7..9})
+inherit distutils-r1
+
+DESCRIPTION="Python ctypes wrapper for libsodium"
+HOMEPAGE="https://libnacl.readthedocs.org/"
+SRC_URI="https://github.com/saltstack/libnacl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~x86"
+
+RDEPEND="dev-libs/libsodium"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/libnacl-1.7.2-32bit.patch
+)
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v -p 'test_*.py' tests/ || die "Tests failed with ${EPYTHON}"
+}