summaryrefslogtreecommitdiff
path: root/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild')
-rw-r--r--dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild b/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..2c5ab37721e6
--- /dev/null
+++ b/dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libasyncns"
+HOMEPAGE="https://launchpad.net/libasyncns-python/"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-libs/libasyncns-0.4"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.7.1-glibc-2.25.patch" )
+
+python_compile() {
+ if [[ ${EPYTHON} != python3* ]]; then
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+ distutils-r1_python_compile
+}
+
+# Tests are network-dependent