summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyterlab')
-rw-r--r--dev-python/jupyterlab/Manifest4
-rw-r--r--dev-python/jupyterlab/jupyterlab-4.1.5.ebuild78
-rw-r--r--dev-python/jupyterlab/jupyterlab-4.1.6.ebuild2
3 files changed, 2 insertions, 82 deletions
diff --git a/dev-python/jupyterlab/Manifest b/dev-python/jupyterlab/Manifest
index f8c69b2b21f1..57ca3af6b704 100644
--- a/dev-python/jupyterlab/Manifest
+++ b/dev-python/jupyterlab/Manifest
@@ -1,5 +1,3 @@
-DIST jupyterlab-4.1.5.tar.gz 21797132 BLAKE2B f3bb8d2292cfa60392b7e97b7852479767e831c4131e1980deaedbf03332d2fec2f01f3e7a6c0f830528e1d99a77f6092a83eb5303d955165946199aed885ffd SHA512 ddd43d5cf7f3ffe18e3baa846270a61a1c5d588901dcc70a32d30ade29273e9c6975640aa89bc9daf58b7fdfc1eeff2f10a9b3f5d174141cbb13a2622579c15e
DIST jupyterlab-4.1.6.tar.gz 21773628 BLAKE2B b2855ecc4fa0cc892fab9bb79c19a3cec0ea577c9c490571ad4028e9fe35bca87fc61d0035cc889bee14313475825344e1cea69f34af4a908c5d2a304250d983 SHA512 b895aac68c6df3affb47eaebc243ecf7d778228a5adec8b8a047783e341008ab4beb0fe50b92138f765e7a72acfbe906f63f41aebe1a72544fe3030105d52716
-EBUILD jupyterlab-4.1.5.ebuild 2657 BLAKE2B a254a6243de8ca8dfa0716385f8b79adc979dc111788ed9a468015fba3b3ce2b642c62330a2993b63c4c257ffbac1016159aba4ccc462ac5834d516c76a40674 SHA512 a459f3fe02af80092137d4b889eadbb833c3fff5b669cd68395b2cfd7cc7991ab939da163110377546755355d843e4c56175873760440074f9a559b112f26d73
-EBUILD jupyterlab-4.1.6.ebuild 2713 BLAKE2B 92175ebeb5c57dc759dcf60b034fb8574744f215406759f570d5cd5fa53ae16cee4855432c1462f59917f8429a17813fd941233d4708f2510b8255bd426fe8ba SHA512 d6be6320d899cc1a4c4155b900805d2d8da01fc515cd322738009ff2aa458d5fa82b2218abcd69e99ea9ef731aba6de031f00bcbd5577ab543b3797bcc2d9962
+EBUILD jupyterlab-4.1.6.ebuild 2708 BLAKE2B 547a7dab63086e024ef88cbbbfd36a6010439a35a6373def8fa8fdcd47319c50b285035c3c55dc11a0dae4a26a942918a7f24cc41cd33b175595dbf57f7a1dfc SHA512 8190341f95ed38b654a53cc7fb22b24ce7ab1194509000b26525465566eb45ca40fedd05102a95cb9914db0f4aa840492c5ab45fecce83de8e1c79b0390fa9a1
MISC metadata.xml 412 BLAKE2B f0b40e19f8ba9dc116f0e4a882cabab6376f22d1eaeb3eac58ecff465ee2aff3564ddbf55e4ffb8971807a39945109a164037a954419671a274d3ac558b102ea SHA512 b6149a03585ca04bc3bf6f3ea6055e8e1fcb620a771359d150df7c22ee16bf09f57c8037df2161021fac0c194be0ac5ec79a31f0511d785e0c5b1ca96d817e42
diff --git a/dev-python/jupyterlab/jupyterlab-4.1.5.ebuild b/dev-python/jupyterlab/jupyterlab-4.1.5.ebuild
deleted file mode 100644
index 72f5ef9f095b..000000000000
--- a/dev-python/jupyterlab/jupyterlab-4.1.5.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi xdg
-
-DESCRIPTION="JupyterLab computational environment"
-HOMEPAGE="
- https://jupyter.org/
- https://github.com/jupyterlab/jupyterlab/
- https://pypi.org/project/jupyterlab/
-"
-
-LICENSE="BSD MIT GPL-3 Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc64 ~riscv x86"
-
-RDEPEND="
- dev-python/async-lru[${PYTHON_USEDEP}]
- >=dev-python/httpx-0.25.0[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
- dev-python/jupyter-core[${PYTHON_USEDEP}]
- >=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/jupyter-server-2.4.0[${PYTHON_USEDEP}]
- <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
- >=dev-python/jupyterlab-server-2.19[${PYTHON_USEDEP}]
- <dev-python/jupyterlab-server-3[${PYTHON_USEDEP}]
- >=dev-python/notebook-shim-0.2[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/tomli[${PYTHON_USEDEP}]
- >=dev-python/tornado-6.2.0[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
- net-libs/nodejs
-"
-
-BDEPEND="
- dev-python/hatch-jupyter-builder[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
- >=dev-python/pytest-jupyter-0.5.3[${PYTHON_USEDEP}]
- dev-python/pytest-tornasync[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/requests-cache[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_DESELECT=(
- # These tests call npm and want internet
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
- jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
- jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
- jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
-)
-
-EPYTEST_IGNORE=(
- jupyterlab/tests/test_announcements.py
-)
-
-distutils_enable_tests pytest
-# TODO: package sphinx_copybutton
-#distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme dev-python/myst-parser
-
-python_install_all() {
- distutils-r1_python_install_all
- mv "${ED}/usr/etc" "${ED}/etc" || die
-}
diff --git a/dev-python/jupyterlab/jupyterlab-4.1.6.ebuild b/dev-python/jupyterlab/jupyterlab-4.1.6.ebuild
index 46f511433227..ca57d8ddb5cc 100644
--- a/dev-python/jupyterlab/jupyterlab-4.1.6.ebuild
+++ b/dev-python/jupyterlab/jupyterlab-4.1.6.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="BSD MIT GPL-3 Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+KEYWORDS="amd64 arm arm64 ~loong ppc64 ~riscv x86"
RDEPEND="
dev-python/async-lru[${PYTHON_USEDEP}]