summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyterlab')
-rw-r--r--dev-python/jupyterlab/Manifest2
-rw-r--r--dev-python/jupyterlab/jupyterlab-4.2.1.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/jupyterlab/Manifest b/dev-python/jupyterlab/Manifest
index 4ebe909cf042..67b51e019d49 100644
--- a/dev-python/jupyterlab/Manifest
+++ b/dev-python/jupyterlab/Manifest
@@ -1,5 +1,7 @@
DIST jupyterlab-4.1.8.tar.gz 21774267 BLAKE2B d707257b2f7c53c023fa0e2741ff1ddbb83116c1b8cc8136b550c94120737161c519c4a2e67211fff275267ab31c58e58b17ea6041e9ba00d44baa1919876f1e SHA512 376b9a9b154b70716ca8450126b9623932b44c88b1a83e42fadc4b98f5a3dd3982d77ae9fc807f483fbd84615c184dd8c170297002c9f609b81755aec21e1ff4
DIST jupyterlab-4.2.0.tar.gz 21488098 BLAKE2B 7857d2ba970b095cf2bd47a7786e47e6aa687a189d165fb04f5685b7848cf9647011a7145cd1a2f351c8f2bc4f876217225583749158b803c4899098ec03be7d SHA512 ee3d99ecd27c44ea9f97b6fbef7e5e0571b0371e5e745d56978151332c840247e1e3464a1947d7df72274032d87c6182cd90f1952669693e3ff72e2c03776e04
+DIST jupyterlab-4.2.1.tar.gz 21505297 BLAKE2B 10f3ed9a3f223623b7414f24791dfe488bc5b94a1bef8c4dae462c246c03fc265254516d39452c79a9226a44afd0fb0a8d3a1b5958f8fd34b125b79c0694e85a SHA512 0235d1561a043c75613289204242c349dcee55ae2c30e4fb3dd04ac4ca5bc13d57d13926603e46a64dcc46aeb3cbc8b5eaad56c3824760ac54e62d20d6eb2b8c
EBUILD jupyterlab-4.1.8.ebuild 2710 BLAKE2B 1fec0b44c47ba7e432ba224b8d24a190933b4b0b84add72d5a1ed71e3e3456957cc93f6a3e012bab67ca97dfdc89656e72098eae942b9a9455e5e76743be5524 SHA512 0fd02aa6a288e137d529c14720fecaa4e5e66ff66d02c9e1f87a4c213b7be811a9035bfeea2b590131064d6b223eaac3fac0866b9a26fde094dff838daf5e810
EBUILD jupyterlab-4.2.0.ebuild 2710 BLAKE2B 1fec0b44c47ba7e432ba224b8d24a190933b4b0b84add72d5a1ed71e3e3456957cc93f6a3e012bab67ca97dfdc89656e72098eae942b9a9455e5e76743be5524 SHA512 0fd02aa6a288e137d529c14720fecaa4e5e66ff66d02c9e1f87a4c213b7be811a9035bfeea2b590131064d6b223eaac3fac0866b9a26fde094dff838daf5e810
+EBUILD jupyterlab-4.2.1.ebuild 2715 BLAKE2B b39a39ab369b5c4d9c315b7c2b219877d42de365badc49ee9c3f24adb6b9d35185540c1eff5a0187f160d33d1fcaa6d29d4897306a45b3db72f9cb3a88c4655e SHA512 ce1ae7035f29395c83a0ac5e2c2a5f96734898e50890e6a956c284efab56997cde2ad5eba8aa445a02659faea9ba413367318d2153f6697476223417e76a87a8
MISC metadata.xml 412 BLAKE2B f0b40e19f8ba9dc116f0e4a882cabab6376f22d1eaeb3eac58ecff465ee2aff3564ddbf55e4ffb8971807a39945109a164037a954419671a274d3ac558b102ea SHA512 b6149a03585ca04bc3bf6f3ea6055e8e1fcb620a771359d150df7c22ee16bf09f57c8037df2161021fac0c194be0ac5ec79a31f0511d785e0c5b1ca96d817e42
diff --git a/dev-python/jupyterlab/jupyterlab-4.2.1.ebuild b/dev-python/jupyterlab/jupyterlab-4.2.1.ebuild
new file mode 100644
index 000000000000..b655c8c83338
--- /dev/null
+++ b/dev-python/jupyterlab/jupyterlab-4.2.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi xdg
+
+DESCRIPTION="JupyterLab computational environment"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab/
+ https://pypi.org/project/jupyterlab/
+"
+
+LICENSE="BSD MIT GPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/async-lru[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-6.5.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ dev-python/jupyter-core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-server-2.27.1[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-server-3[${PYTHON_USEDEP}]
+ >=dev-python/notebook-shim-0.2[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/tornado-6.2.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ net-libs/nodejs
+"
+
+BDEPEND="
+ dev-python/hatch-jupyter-builder[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-cache[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # These tests call npm and want internet
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
+)
+
+EPYTEST_IGNORE=(
+ jupyterlab/tests/test_announcements.py
+)
+
+distutils_enable_tests pytest
+# TODO: package sphinx_copybutton
+#distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme dev-python/myst-parser
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}