summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab-lsp
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyterlab-lsp')
-rw-r--r--dev-python/jupyterlab-lsp/Manifest4
-rw-r--r--dev-python/jupyterlab-lsp/jupyterlab-lsp-3.9.1.ebuild22
-rw-r--r--dev-python/jupyterlab-lsp/metadata.xml2
3 files changed, 26 insertions, 2 deletions
diff --git a/dev-python/jupyterlab-lsp/Manifest b/dev-python/jupyterlab-lsp/Manifest
index 4bdfd9b2114e..2b78c14fc158 100644
--- a/dev-python/jupyterlab-lsp/Manifest
+++ b/dev-python/jupyterlab-lsp/Manifest
@@ -1,3 +1,5 @@
DIST jupyterlab-lsp-3.8.1.tar.gz 249073 BLAKE2B 1ab252fdc8868e997432704869f189fa814c292f7f34ec9f382bf94f4de65d35530f61ea7605176f2356e5b99db812746b78348cb27845c0168afb0498b93f2b SHA512 61840c2d206d3a107d43b97d222d76959d577ef63e0835a249e7201e50b6ce5f0abf067d0d4be928b9b451809e2e6e75803cf4450f71441018495fa17500067c
+DIST jupyterlab-lsp-3.9.1.tar.gz 262645 BLAKE2B cd3377ea3abbb3f877b257140d5ac6b162aa9d4229cb58f67fa60a9b7f5db43de6873af381bac5bbf6103a47a53863ae322ad200550d73e5c19baa5eb2866aa2 SHA512 0289dc666a3ec3d93d276c67e95c19b0427e45a4f1e001180df4af9a72f7e81dddc8bdd175684f857dfc8e02935dbd31b454bfd0ee1431a8e702f662365c747e
EBUILD jupyterlab-lsp-3.8.1.ebuild 557 BLAKE2B 09af4665d81544bef9f7c6e1b1f5521a1e9f390b2197d46f6a223723ac06353f155ccba19af40f6afa661791334b2373c8aeee61616ba6e6361d6735c540e69b SHA512 c12230c35af906157a12c403e3e0679724b232e3dbd292126d070965df3ebb2c0195aa0a337fee29b8a0acb7a12ad72d671aa3c211fe89eabc30b6b6b3f106ca
-MISC metadata.xml 420 BLAKE2B 902f6c4cc0d4f5c82359aff123ad039754e09e8b791fa9e3e2b71bf62f4348f412c6f73b09556b24cb5d0b9cb54e35358a93b26a8b73cf393088a3766857e220 SHA512 14ae0ba26d061fa091435c8a45df2af9d239320ad0dbd249a1f7ea6c2bc1b6dff7ff921134e6c484419b61719a44c4485110669f5c14fc92c940baf4eabd2718
+EBUILD jupyterlab-lsp-3.9.1.ebuild 558 BLAKE2B 6e9104b1c9cc3f8113cd1026eab02cc6a08c4d5a183a571c0c0a4072170c179f9502d404ca47209e52315b52d902605d431f595ab92e884d28a789979f1670e4 SHA512 87f6f9d409f870c29bda45b21885b0a4fdcc8fa4262c5b16fae185987745cb008f8bf308bce819cfce722d9cc725c945a9f538ffd77804ab221e73bf3ca13832
+MISC metadata.xml 421 BLAKE2B cbd9c4e3ce5848ed3d0e57832082dd730d2d16a286070639602b8fcd49c49714e7f17b220251b9f16d9c5105248933390b152c060c68522d2c82b1958b09b116 SHA512 97ac68ac4e6920f23120a5818b4404fa0b510b165a44a6455a7bf76edfa298ca137f50bd9c1a87044253f5b873f881362c2667261a4c7fdb182a7d37325520b3
diff --git a/dev-python/jupyterlab-lsp/jupyterlab-lsp-3.9.1.ebuild b/dev-python/jupyterlab-lsp/jupyterlab-lsp-3.9.1.ebuild
new file mode 100644
index 000000000000..c25e67aafe2b
--- /dev/null
+++ b/dev-python/jupyterlab-lsp/jupyterlab-lsp-3.9.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Coding assistance for JupyterLab with Language Server Protocol"
+HOMEPAGE="https://github.com/jupyter-lsp/jupyterlab-lsp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jupyterlab-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-1.4.0[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/jupyterlab-lsp/metadata.xml b/dev-python/jupyterlab-lsp/metadata.xml
index 17504c44ca44..e79436c3ba8c 100644
--- a/dev-python/jupyterlab-lsp/metadata.xml
+++ b/dev-python/jupyterlab-lsp/metadata.xml
@@ -8,6 +8,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">jupyterlab-lsp</remote-id>
- <remote-id type="github">krassowski/jupyterlab-lsp</remote-id>
+ <remote-id type="github">jupyter-lsp/jupyterlab-lsp</remote-id>
</upstream>
</pkgmetadata>