summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyterlab')
-rw-r--r--dev-python/jupyterlab/Manifest4
-rw-r--r--dev-python/jupyterlab/jupyterlab-4.3.3.ebuild81
-rw-r--r--dev-python/jupyterlab/jupyterlab-4.3.4.ebuild81
3 files changed, 166 insertions, 0 deletions
diff --git a/dev-python/jupyterlab/Manifest b/dev-python/jupyterlab/Manifest
index d296bb0bacf4..7f6aa65acc5d 100644
--- a/dev-python/jupyterlab/Manifest
+++ b/dev-python/jupyterlab/Manifest
@@ -1,5 +1,9 @@
DIST jupyterlab-4.2.5.tar.gz 21508698 BLAKE2B 9222972e40e60549360d80221b97806e47b70592ffa9a63b3cb030e4b4ad061a8f8eadf295d76ae0302efb3bbf854cde9f5dfcacb6df3c6ad1994bf6ab66d1cc SHA512 7c5c3aab1bf86da0e49742630ece8a311ec351be99bfce3e35b5e92e06e858296e882a47f7a1abe9ab1c63cc92062f21d557f4f6237846a3c8377fc6288bf298
DIST jupyterlab-4.3.2.tar.gz 21797175 BLAKE2B 72626351e0cadb523a8fc8a3b5ce7c6f452755eb145a5ac1c07118a0fbe2830025f78f94015381097360a171f9f4f5903fe71c3941d931db633328869caf5a28 SHA512 44e364b4bed7985394cfc28f2a7ff5e82c78861d61021886816c2ff26c9fca68140e956d281726433e63eee8f076ca35131ca930341430023c3043ee297981e2
+DIST jupyterlab-4.3.3.tar.gz 21797278 BLAKE2B d68dbe86e2d7a94a862f6323920b1b725ff5595e01834c36cdced4a56ff8b2860ab23321da0fa4d22fb93c6e7dd98013892d61c4c7ea4425de02d695dceb78cb SHA512 6cd2a3c68adf824ef586eb8df52bc878ee32cc26395a0aa47212fbb10e8e435efe5005dad875771910de9839694eb28eabb2e9e548416500ce5d1aa37f27e1f1
+DIST jupyterlab-4.3.4.tar.gz 21797583 BLAKE2B 6b3cf186992edd58dd02e77e58c5e729391468438ab04a18a59b286adb9d8db677c14878eb09cc2d8857dd80915dd7191ae8bd24abaa1f7d96e8c76785ae0a57 SHA512 e9d46ec06f5bca037d45a9c6ef811a1927db3e1fb32996592676f8578563d4a24aaad82facf4f75014740711247d66a8362d2e344537d4952c2af3a9e5bdf9e3
EBUILD jupyterlab-4.2.5.ebuild 2761 BLAKE2B 1790fad4e737b686bfba5d2ecfb4093ce8d7746912debec0a94f7fa87e7d34bf7f34c977da74e51bc1c0e1a9d69002df915e0cb4042c4d21bdbaf24123047db2 SHA512 062b8d986c027db40e09d41024aa5901b6f25cd86b5322c00f2ca2c68e8957fe83c8c7782d0294af8643fdaa29369889b049994c6593a2c377737b864aef3e3f
EBUILD jupyterlab-4.3.2.ebuild 2779 BLAKE2B 692a73559917255d98b29947f37996d6a82e426eba75549971c96069ad31ee2720429313ffece75199d95d73db5db8d30cb191e4a772f9a2c31fd99a64a99b1e SHA512 a3c910cf013dfc83abd7629e89e87469f38b91839b40775dd3df50284fc4e4ef512a88b54f6419b0d26a625caac1157966e1c5cf8c197a4a3e7d1e0288897a55
+EBUILD jupyterlab-4.3.3.ebuild 2779 BLAKE2B 692a73559917255d98b29947f37996d6a82e426eba75549971c96069ad31ee2720429313ffece75199d95d73db5db8d30cb191e4a772f9a2c31fd99a64a99b1e SHA512 a3c910cf013dfc83abd7629e89e87469f38b91839b40775dd3df50284fc4e4ef512a88b54f6419b0d26a625caac1157966e1c5cf8c197a4a3e7d1e0288897a55
+EBUILD jupyterlab-4.3.4.ebuild 2779 BLAKE2B 692a73559917255d98b29947f37996d6a82e426eba75549971c96069ad31ee2720429313ffece75199d95d73db5db8d30cb191e4a772f9a2c31fd99a64a99b1e SHA512 a3c910cf013dfc83abd7629e89e87469f38b91839b40775dd3df50284fc4e4ef512a88b54f6419b0d26a625caac1157966e1c5cf8c197a4a3e7d1e0288897a55
MISC metadata.xml 412 BLAKE2B f0b40e19f8ba9dc116f0e4a882cabab6376f22d1eaeb3eac58ecff465ee2aff3564ddbf55e4ffb8971807a39945109a164037a954419671a274d3ac558b102ea SHA512 b6149a03585ca04bc3bf6f3ea6055e8e1fcb620a771359d150df7c22ee16bf09f57c8037df2161021fac0c194be0ac5ec79a31f0511d785e0c5b1ca96d817e42
diff --git a/dev-python/jupyterlab/jupyterlab-4.3.3.ebuild b/dev-python/jupyterlab/jupyterlab-4.3.3.ebuild
new file mode 100644
index 000000000000..30f9428b6455
--- /dev/null
+++ b/dev-python/jupyterlab/jupyterlab-4.3.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi xdg
+
+DESCRIPTION="JupyterLab computational environment"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab/
+ https://pypi.org/project/jupyterlab/
+"
+
+LICENSE="BSD MIT GPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/async-lru-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.28.0[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-6.5.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja2-3.0.3[${PYTHON_USEDEP}]
+ dev-python/jupyter-core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-server-2.27.1[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-server-3[${PYTHON_USEDEP}]
+ >=dev-python/notebook-shim-0.2[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-40.8.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/tornado-6.2.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ net-libs/nodejs[npm]
+"
+
+BDEPEND="
+ dev-python/hatch-jupyter-builder[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-cache[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # These tests call npm and want internet
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
+)
+
+EPYTEST_IGNORE=(
+ jupyterlab/tests/test_announcements.py
+)
+
+distutils_enable_tests pytest
+# TODO: package sphinx_copybutton
+#distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme dev-python/myst-parser
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
diff --git a/dev-python/jupyterlab/jupyterlab-4.3.4.ebuild b/dev-python/jupyterlab/jupyterlab-4.3.4.ebuild
new file mode 100644
index 000000000000..30f9428b6455
--- /dev/null
+++ b/dev-python/jupyterlab/jupyterlab-4.3.4.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi xdg
+
+DESCRIPTION="JupyterLab computational environment"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab/
+ https://pypi.org/project/jupyterlab/
+"
+
+LICENSE="BSD MIT GPL-3 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/async-lru-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.28.0[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-6.5.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja2-3.0.3[${PYTHON_USEDEP}]
+ dev-python/jupyter-core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-server-2.27.1[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-server-3[${PYTHON_USEDEP}]
+ >=dev-python/notebook-shim-0.2[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-40.8.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/tornado-6.2.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ net-libs/nodejs[npm]
+"
+
+BDEPEND="
+ dev-python/hatch-jupyter-builder[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-cache[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # These tests call npm and want internet
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_uninstall_core_extension
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned_folder
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_install_and_uninstall_pinned
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom_minimal_core_config
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_custom
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build_check
+ jupyterlab/tests/test_jupyterlab.py::TestExtension::test_build
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_clear
+ jupyterlab/tests/test_build_api.py::TestBuildAPI::test_build
+)
+
+EPYTEST_IGNORE=(
+ jupyterlab/tests/test_announcements.py
+)
+
+distutils_enable_tests pytest
+# TODO: package sphinx_copybutton
+#distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme dev-python/myst-parser
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}