summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_ydoc
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyter_ydoc')
-rw-r--r--dev-python/jupyter_ydoc/Manifest4
-rw-r--r--dev-python/jupyter_ydoc/files/jupyter_ydoc-0.3.1-no-node-for-version.patch30
-rw-r--r--dev-python/jupyter_ydoc/jupyter_ydoc-0.3.1.ebuild46
-rw-r--r--dev-python/jupyter_ydoc/metadata.xml13
4 files changed, 93 insertions, 0 deletions
diff --git a/dev-python/jupyter_ydoc/Manifest b/dev-python/jupyter_ydoc/Manifest
new file mode 100644
index 000000000000..c3ac7fcdfd8c
--- /dev/null
+++ b/dev-python/jupyter_ydoc/Manifest
@@ -0,0 +1,4 @@
+AUX jupyter_ydoc-0.3.1-no-node-for-version.patch 846 BLAKE2B e2db718c5c7f1fd04a720e0eed00158bf657b931462274090740d6a11d37b7dc4e1493414e0490ace783ff91c01cd052fad00db1651192eb6fd1618ab68fc420 SHA512 827b79a02c933b902d75aeb997b6abd25a867b0ef978f2ba78f689897545552560d31e472207b6048b63605db40799eb5b10cfaf0b502c621278a48f96ac6a22
+DIST jupyter_ydoc-0.3.1.gh.tar.gz 170182 BLAKE2B 6a3b000b47bb00ddb8f6ddecb1091a150dbb33dadcb8ecfe8d55a03050663ee9dacbe1b8063174f54cca5472a6245951ba8ce3137afedea17735d1c5679690fc SHA512 897779f39cf2ffb0e59db31745063d2482d165ee76ca4cedb131b8daed341a63826af150a6da013226febc99d1bd0376fc003ff179744e81ec619993c04ffdd0
+EBUILD jupyter_ydoc-0.3.1.ebuild 1075 BLAKE2B 727cafaa76ba2b0ddb12d7f0990e820808785081f783e256f3137c1dee52212a8d4ec0f9af4c0756b3bb88e90004cf1baa6fc8de0a3e572a3c43c1ffc3b4a13b SHA512 0383dc0484e249b32dae9bb495fed02cb44b5af6cd162f575e5fdc4f7f4f2a42e19b27604a2b6562a1413f91781332cf03bdb35fcb8b22642af3febc21b30a05
+MISC metadata.xml 433 BLAKE2B cf2579c7d85eefe97d8ec81f37ac5e10deee9aaf52b16cea8ce3649f6076a3afee9e7ce6efbf82cd7713421353b53c16ed4d28b03a9b6e8b5c029fc6f3615651 SHA512 1258a3f0bd2a959055312594eb72bcd06fd639cf777543b41919da60b4082d241ad87231bdfb8c2ef057c85657875ac596b732301d3fb0c9a10cea5d2746234f
diff --git a/dev-python/jupyter_ydoc/files/jupyter_ydoc-0.3.1-no-node-for-version.patch b/dev-python/jupyter_ydoc/files/jupyter_ydoc-0.3.1-no-node-for-version.patch
new file mode 100644
index 000000000000..0c337ec90d7d
--- /dev/null
+++ b/dev-python/jupyter_ydoc/files/jupyter_ydoc-0.3.1-no-node-for-version.patch
@@ -0,0 +1,30 @@
+diff --git a/pyproject.toml b/pyproject.toml
+index 6e0a069..42f76c1 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -2,12 +2,12 @@
+ # Distributed under the terms of the Modified BSD License.
+
+ [build-system]
+-requires = ["hatchling>=1.10.0", "hatch-nodejs-version"]
++requires = ["hatchling>=1.10.0"]
+ build-backend = "hatchling.build"
+
+ [project]
+ name = "jupyter-ydoc"
+-dynamic = ["version"]
++version = "0.3.1"
+ description = "Document structures for collaborative editing using Ypy"
+ requires-python = ">=3.7"
+ keywords = ["jupyter", "ypy"]
+@@ -56,10 +56,6 @@ text = "BSD 3-Clause License"
+ Homepage = "https://jupyter.org"
+ Source = "https://github.com/jupyter-server/jupyter_ydoc"
+
+-[tool.hatch.version]
+-source = "nodejs"
+-path = "javascript/package.json"
+-
+ [tool.hatch.build]
+ exclude = ["javascript", "!javascript/package.json"]
+
diff --git a/dev-python/jupyter_ydoc/jupyter_ydoc-0.3.1.ebuild b/dev-python/jupyter_ydoc/jupyter_ydoc-0.3.1.ebuild
new file mode 100644
index 000000000000..ea9984a94ac7
--- /dev/null
+++ b/dev-python/jupyter_ydoc/jupyter_ydoc-0.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Document structures for collaborative editing using Ypy"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/jupyter_ydoc/
+ https://pypi.org/project/jupyter-ydoc/
+"
+SRC_URI="https://github.com/jupyter-server/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Requires node
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/y-py[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ dev-python/ypy-websocket[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-node-for-version.patch"
+)
+
+distutils_enable_tests pytest
+# Hangs for some reason
+#distutils_enable_sphinx docs/source dev-python/myst_parser dev-python/pydata-sphinx-theme
diff --git a/dev-python/jupyter_ydoc/metadata.xml b/dev-python/jupyter_ydoc/metadata.xml
new file mode 100644
index 000000000000..a7e33c55e1cf
--- /dev/null
+++ b/dev-python/jupyter_ydoc/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">jupyter-ydoc</remote-id>
+ <remote-id type="github">jupyter-server/jupyter_ydoc</remote-id>
+ </upstream>
+</pkgmetadata>