summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_core/jupyter_core-4.11.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyter_core/jupyter_core-4.11.2.ebuild')
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.11.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/jupyter_core-4.11.2.ebuild b/dev-python/jupyter_core/jupyter_core-4.11.2.ebuild
new file mode 100644
index 000000000000..f7de21236410
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-4.11.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_core/
+ https://pypi.org/project/jupyter-core/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-github-alt
+distutils_enable_tests pytest