summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_client/jupyter_client-6.1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyter_client/jupyter_client-6.1.5.ebuild')
-rw-r--r--dev-python/jupyter_client/jupyter_client-6.1.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/jupyter_client-6.1.5.ebuild b/dev-python/jupyter_client/jupyter_client-6.1.5.ebuild
new file mode 100644
index 000000000000..2bf01c589f1a
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-6.1.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest