summaryrefslogtreecommitdiff
path: root/dev-python/jupyter-events/jupyter-events-0.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyter-events/jupyter-events-0.9.1.ebuild')
-rw-r--r--dev-python/jupyter-events/jupyter-events-0.9.1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/jupyter-events/jupyter-events-0.9.1.ebuild b/dev-python/jupyter-events/jupyter-events-0.9.1.ebuild
deleted file mode 100644
index bf33bb189671..000000000000
--- a/dev-python/jupyter-events/jupyter-events-0.9.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Jupyter Event System library"
-HOMEPAGE="
- https://jupyter.org/
- https://github.com/jupyter/jupyter_events/
- https://pypi.org/project/jupyter-events/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-# jsonschema[format-nongpl] deps are always on in our ebuild
-RDEPEND="
- >=dev-python/jsonschema-4.18.0[${PYTHON_USEDEP}]
- >=dev-python/python-json-logger-2.0.4[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.3[${PYTHON_USEDEP}]
- dev-python/referencing[${PYTHON_USEDEP}]
- >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- )
-"
-
-# TODO: package jupyterlite-sphinx
-# distutils_enable_sphinx docs
-distutils_enable_tests pytest