summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema/jsonschema-3.2.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonschema/jsonschema-3.2.0-r1.ebuild')
-rw-r--r--dev-python/jsonschema/jsonschema-3.2.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/jsonschema/jsonschema-3.2.0-r1.ebuild b/dev-python/jsonschema/jsonschema-3.2.0-r1.ebuild
new file mode 100644
index 000000000000..a1a69cca3a4a
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-3.2.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="https://pypi.org/project/jsonschema/ https://github.com/Julian/jsonschema"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ test? ( dev-python/twisted[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="${BDEPEND}
+ dev-python/idna[${PYTHON_USEDEP}]
+ >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/webcolors[${PYTHON_USEDEP}]
+ dev-python/rfc3986-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+"
+
+BDEPEND+="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-add-webcolors-1.11-compat.patch
+)
+
+distutils_enable_tests unittest