summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema/jsonschema-2.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonschema/jsonschema-2.3.0.ebuild')
-rw-r--r--dev-python/jsonschema/jsonschema-2.3.0.ebuild25
1 files changed, 0 insertions, 25 deletions
diff --git a/dev-python/jsonschema/jsonschema-2.3.0.ebuild b/dev-python/jsonschema/jsonschema-2.3.0.ebuild
deleted file mode 100644
index a68173a0b00f..000000000000
--- a/dev-python/jsonschema/jsonschema-2.3.0.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=(python2_7)
-inherit distutils-r1
-
-DESCRIPTION="An implementation of JSON-Schema validation for Python"
-HOMEPAGE="https://pypi.org/project/jsonschema/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-python_test() {
- local runner=( "${PYTHON}" -m unittest )
- if [[ ${EPYTHON} == python2.6 || ${EPYTHON} == python3.1 ]]; then
- unset PYTHONPATH
- runner=( unit2.py )
- fi
- "${runner[@]}" discover || die "Testing failed with ${EPYTHON}"
-}