summaryrefslogtreecommitdiff
path: root/dev-python/jsonrpclib
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonrpclib')
-rw-r--r--dev-python/jsonrpclib/Manifest6
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-0.3.1.ebuild30
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-0_pre20110820-r1.ebuild26
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-9999.ebuild30
-rw-r--r--dev-python/jsonrpclib/metadata.xml15
5 files changed, 107 insertions, 0 deletions
diff --git a/dev-python/jsonrpclib/Manifest b/dev-python/jsonrpclib/Manifest
new file mode 100644
index 000000000000..942c94cef88f
--- /dev/null
+++ b/dev-python/jsonrpclib/Manifest
@@ -0,0 +1,6 @@
+DIST jsonrpclib-0.3.1.tar.gz 42704 BLAKE2B e3c83bb25ec83a93fdde8f6f4b8b18de0d0ddd0cc35c04f9f83b1f0e75803211a6f6b85768b0c7f9de4bcac18df721df8057148aa7aa0628dd1d345c2e4d90e1 SHA512 7cd44d44f3952ee7ac4006904427ddd3a69b60e6a0a4eaff4b75d03b1c30f7a65debd69552035a4ee375a33c80ec428fc1ef10979f55316bcfd015603c62304f
+DIST jsonrpclib-0_pre20110820.tar.bz2 14608 BLAKE2B 1cc7fea4984009c1c21d9dfd9cabec10d48406294262b973dcf5f3d3148fc74be5f201ee11c91600e7b6679dbd5716d197d727c89da738d2dc54aa9a0e1dec82 SHA512 80864890982c4a11996cd9fae21029cdf40b089eb6c2d265c645f52fe0a6e858b3405c5d899d2a5908527da04263d93064f365c5308adda1791105bf32329b71
+EBUILD jsonrpclib-0.3.1.ebuild 707 BLAKE2B ed9cdad9fca836dbeb2873a6943c3ffa63655698a51e153a22b56097d91275f36d8ebc8d93cbf36b42676a57d0bf804a6cd1d157fb86edce75586b26892fdc3a SHA512 94d249b89a7def1f402ec979d3969353c7179f56c29088584e2220ba288e2853af40ea24c2447ea13fb4fa8b3a3fe0cbbc1789f8e92f98aca77845b925f1ffa7
+EBUILD jsonrpclib-0_pre20110820-r1.ebuild 573 BLAKE2B d78437cbefdcc6f269bcc1139deeb82a7ad2c96bd4313851d57aca21635a7fd784545f9487ccfa1eacf74f093e80d76294b697a85004e7e6f0ce094b045d6995 SHA512 10a9c32643d393ff9f857eb2d48d708d1635cc52d3369bac0abe05d0cb29b67295d49126380f5c880dd61d83e0676a1934a9610e95c8a0217e1e920964b1b800
+EBUILD jsonrpclib-9999.ebuild 710 BLAKE2B 563d5e0e4946e3912d6b87d60016bedecf8413d6947e48b1b0e77a2ae7519cfdbaf6ef4f09f2a4635e890db2016e9866f0c3a9dc56491aa6b0d60c2de912a2a3 SHA512 a1ddbb9900c1aa49fdb6c758b134c5ae00e9f17ca0ae17faf36a5024ce194ab00b80b583d65a4bce281defde4148ea0816b4e01c2a516ba707569fe22c9b073b
+MISC metadata.xml 453 BLAKE2B 852b07f16a1773b07d2efebb8bb338c972a807fe2c7cb99fdfe62a2c6cdcb63098b9b76a2e9173af8f397ab5aea724732296882689fa42dd66381543d84246b8 SHA512 5ecbc0cc593546cfc7bb86cb789df99aa25e38c215971c35e0dab83d6134348f591db126f62f4a578728922b2aaad0d664b797edd85324b51c6b9e6ec0cd264e
diff --git a/dev-python/jsonrpclib/jsonrpclib-0.3.1.ebuild b/dev-python/jsonrpclib/jsonrpclib-0.3.1.ebuild
new file mode 100644
index 000000000000..59c5ed43ca51
--- /dev/null
+++ b/dev-python/jsonrpclib/jsonrpclib-0.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/tcalmant/jsonrpclib.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tcalmant/jsonrpclib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 arm ~mips x86"
+fi
+
+DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
+HOMEPAGE="https://github.com/tcalmant/jsonrpclib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/simplejson"
+
+python_test() {
+ esetup.py test || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/jsonrpclib/jsonrpclib-0_pre20110820-r1.ebuild b/dev-python/jsonrpclib/jsonrpclib-0_pre20110820-r1.ebuild
new file mode 100644
index 000000000000..1d9c9ecb9b6a
--- /dev/null
+++ b/dev-python/jsonrpclib/jsonrpclib-0_pre20110820-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/joshmarshall/jsonrpclib.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ KEYWORDS="amd64 arm x86"
+fi
+
+DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
+HOMEPAGE="https://github.com/joshmarshall/jsonrpclib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/simplejson"
diff --git a/dev-python/jsonrpclib/jsonrpclib-9999.ebuild b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
new file mode 100644
index 000000000000..de6e1a8301bc
--- /dev/null
+++ b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/tcalmant/jsonrpclib.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tcalmant/jsonrpclib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~mips ~x86"
+fi
+
+DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
+HOMEPAGE="https://github.com/tcalmant/jsonrpclib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/simplejson"
+
+python_test() {
+ esetup.py test || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/jsonrpclib/metadata.xml b/dev-python/jsonrpclib/metadata.xml
new file mode 100644
index 000000000000..227e6b1f2cbe
--- /dev/null
+++ b/dev-python/jsonrpclib/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tcalmant/jsonrpclib</remote-id>
+ </upstream>
+</pkgmetadata>