summaryrefslogtreecommitdiff
path: root/dev-python/jsondiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsondiff')
-rw-r--r--dev-python/jsondiff/Manifest3
-rw-r--r--dev-python/jsondiff/jsondiff-1.1.2.ebuild33
-rw-r--r--dev-python/jsondiff/metadata.xml13
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/jsondiff/Manifest b/dev-python/jsondiff/Manifest
new file mode 100644
index 000000000000..7221b806b2c5
--- /dev/null
+++ b/dev-python/jsondiff/Manifest
@@ -0,0 +1,3 @@
+DIST jsondiff-1.1.2.tar.gz 7803 BLAKE2B cbfcfdb2c6c3bb721b4db43aca1d66649257db2cd9feb9655015e621fcd90c72af087696b9553a10ac89cdaf5f23d8748463e1a13bdb19207e34e12e66629544 SHA512 ca96bb80a6f7a34c8c5bcde74856dc1c4935b3e2979330ecfc33432aff83968e671b2aaf310c77f2c7d431be1ae6e20a960879700ba3c903a09a48b23d4c0288
+EBUILD jsondiff-1.1.2.ebuild 850 BLAKE2B bc74275bdec736747e7607022c16d0ebdab4e097fce4e63787db9e719790ac28fc48ee551fa2c67e93576793dda58f9721cd0c69b0988986caa31e65df8000da SHA512 ed1bd63e25afe9e68e1d3e221aa1d97a26d1282ba1e587b1073384fd59aa8f222735a539a47915701f62bf9947c79e029f4c420bd02c0e998c8422e5f1d7c2b0
+MISC metadata.xml 435 BLAKE2B 3ea5af8e9063a07c6d3d93225a712395a351a368bf689e512b45e6225e23a543771839e756ee53cf51142b6309f0b1ecd20fff6203a69ae754c44893d09c5274 SHA512 d1b50f01a0a5f2381fe41e4da073fd00afd4443a76d692c7a2227e50b178e9b990c4c40b72d1beeeab7cc8e5f1a9a52beb758a5adbd088eb787b9f2d08844eff
diff --git a/dev-python/jsondiff/jsondiff-1.1.2.ebuild b/dev-python/jsondiff/jsondiff-1.1.2.ebuild
new file mode 100644
index 000000000000..4f246f930991
--- /dev/null
+++ b/dev-python/jsondiff/jsondiff-1.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Diff JSON and JSON-like structures in Python"
+HOMEPAGE="https://github.com/xlwings/jsondiff https://pypi.org/project/jsondiff/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# tests require nose_random
+RESTRICT="test"
+
+python_prepare_all() {
+ # Avoid file collision with jsonpatch's jsondiff cli.
+ sed -e "/'jsondiff=jsondiff.cli:main'/d" -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jsondiff/metadata.xml b/dev-python/jsondiff/metadata.xml
new file mode 100644
index 000000000000..ff1d5858ae38
--- /dev/null
+++ b/dev-python/jsondiff/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">xlwings/jsondiff</remote-id>
+ <remote-id type="pypi">jsondiff</remote-id>
+ <bugs-to>https://github.com/xlwings/jsondiff/issues</bugs-to>
+ </upstream>
+</pkgmetadata>