summaryrefslogtreecommitdiff
path: root/dev-python/jschema_to_python/jschema_to_python-1.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jschema_to_python/jschema_to_python-1.2.3.ebuild')
-rw-r--r--dev-python/jschema_to_python/jschema_to_python-1.2.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/jschema_to_python/jschema_to_python-1.2.3.ebuild b/dev-python/jschema_to_python/jschema_to_python-1.2.3.ebuild
new file mode 100644
index 000000000000..abe57ddb25df
--- /dev/null
+++ b/dev-python/jschema_to_python/jschema_to_python-1.2.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Generate source code for Python classes from a JSON schema"
+HOMEPAGE="
+ https://pypi.org/project/jschema-to-python/
+ https://github.com/microsoft/jschema-to-python/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/jsonpickle[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest