summaryrefslogtreecommitdiff
path: root/dev-python/jeepney
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jeepney')
-rw-r--r--dev-python/jeepney/Manifest2
-rw-r--r--dev-python/jeepney/jeepney-0.9.0.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/jeepney/Manifest b/dev-python/jeepney/Manifest
index 22b8caaacfd7..7f386c7452e4 100644
--- a/dev-python/jeepney/Manifest
+++ b/dev-python/jeepney/Manifest
@@ -1,3 +1,5 @@
DIST jeepney-0.8.0.tar.gz 106005 BLAKE2B 23dbd876915ca364202b6e1888d5b6892c56020a492f9dbdd22c1e04f40c2627bfb90ce209c69be000e176cc6b144b6c2232a21ce1ab089971911ffa2c22cd2c SHA512 823675f262c2c9778ccf9c1083601d936cca534fc0d2d9309b52aa6beeb7f73d225a37c5f18f6b0683c4829a93b1299a2cb4f8f341e55b92bedf58c8dce0aa75
+DIST jeepney-0.9.0.tar.gz 106758 BLAKE2B 40a19ffaacbb286e645292592573e04098f0604914e796272720bb6af3f927f048d624f34a3443a2b8ae6de8d92dba2d631f1e4bcdd004ea3cb7affcb2f1b504 SHA512 2d47ba3f8b652abe5b5b5cde5cb66600c2914207a45973e3ca28a0561e61d98827751ff32c6019ef9e2507ee5c2879ef1ef0d732870d208b500f7b52f3c6229c
EBUILD jeepney-0.8.0.ebuild 1297 BLAKE2B 168a5260a1d5424cc2477b6f4e8c1abaf89a4bb5ba38904b91ffb6a40e6743096d436485d683acb59ac5e885d3236d4e7c7b3a8b7b28e8234f9797034ab47bf4 SHA512 1eb4b99c9c3fdeb611494099ea5ea7cb29c105defee04275f17ab673b116b7ccd34ad7834c0c26c98f2db620b975eff6058366c78f0aa0c5a408698334cfabcc
+EBUILD jeepney-0.9.0.ebuild 1342 BLAKE2B 80b8fea5922abb5846183fd3031948b86e8045b67b713b71d8a88a4138db68befa1fd9439d50f5bc38ca650b8c78d4af9a1567d9481b21c23624f3c89a00d195 SHA512 30e4d6c6d9a9a9887b443146247a7bbfb238d9d7515fccc2c3ba6ac715743df79d486d6ddb07fa39f3436c98d3d45a3c8f34b39e4e910c965d81f8397ccfabac
MISC metadata.xml 459 BLAKE2B 824ec5e3c8b912403c50b3ece13706636b521c52ca8c386fb7086d703b785f81902d2a34ac2f588ee518134e9e07d23ba21df06cba5f566717c9a41f4e7a4258 SHA512 5b04f7fd929a3242eaa4a8c53357685a0b1372edbdc25be260e7072faca18fec632510580a89ce407983ffe1659b78355a4bedc4090ccfca42a8f1c17ddefd69
diff --git a/dev-python/jeepney/jeepney-0.9.0.ebuild b/dev-python/jeepney/jeepney-0.9.0.ebuild
new file mode 100644
index 000000000000..a52ce8100d00
--- /dev/null
+++ b/dev-python/jeepney/jeepney-0.9.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Low-level, pure Python DBus protocol wrapper"
+HOMEPAGE="
+ https://gitlab.com/takluyver/jeepney/
+ https://pypi.org/project/jeepney/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/async-timeout[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/pytest-asyncio-0.7.1[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ sys-apps/dbus
+ )
+"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+
+src_test() {
+ local dbus_params=(
+ $(dbus-daemon --session --print-address --fork --print-pid)
+ )
+ local -x DBUS_SESSION_BUS_ADDRESS=${dbus_params[0]}
+
+ distutils-r1_src_test
+
+ kill "${dbus_params[1]}" || die
+}
+
+python_test() {
+ local EPYTEST_IGNORE=()
+ if ! has_version "dev-python/pytest-trio[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=( jeepney/io/tests/test_trio.py )
+ fi
+ epytest
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}