summaryrefslogtreecommitdiff
path: root/dev-python/jc/jc-1.16.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jc/jc-1.16.0.ebuild')
-rw-r--r--dev-python/jc/jc-1.16.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/jc/jc-1.16.0.ebuild b/dev-python/jc/jc-1.16.0.ebuild
new file mode 100644
index 000000000000..55a2e83ea478
--- /dev/null
+++ b/dev-python/jc/jc-1.16.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converts the output of popular command-line tools and file-types to JSON"
+HOMEPAGE="https://github.com/kellyjonbrazil/jc"
+SRC_URI="
+ https://github.com/kellyjonbrazil/jc/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest