summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-test
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-test')
-rw-r--r--dev-python/jaraco-test/Manifest2
-rw-r--r--dev-python/jaraco-test/jaraco-test-5.3.0.ebuild38
2 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/jaraco-test/Manifest b/dev-python/jaraco-test/Manifest
index 7ed2a3ec4d32..5ef56bd599fd 100644
--- a/dev-python/jaraco-test/Manifest
+++ b/dev-python/jaraco-test/Manifest
@@ -1,5 +1,3 @@
-DIST jaraco.test-5.3.0.tar.gz 8199 BLAKE2B bb44899e9d459350b7edff1a0212afada0765b250e7450c28e15da958632b33a17777d6db2b7ae9984772928003fbd368b6482889816198c971c77fd1f967bcd SHA512 31d2ea0557023c6996b786ee1b2a385ac8f22c2af66baab98c3a6b894bf1eaa7378a595d00bc46a537cc89fe87c9193733968fc8a586a58654b468b712d63728
DIST jaraco.test-5.4.0.tar.gz 8838 BLAKE2B 3abdff298a61015363bda3e52d3b5226993169128386dbb620487dcf8b29926c9be0415a2a263ad311db04a591d446b9e6efaece2ab2bfbe7b2781ee2e6dcdd6 SHA512 ab260c3c5ef16e83e8be0821cb735941764c06bb414c3f913bf337b62267b177f3102f7a87241b182ef20760fdcce98f4f9c705335b0744b69f9a296d5215b1b
-EBUILD jaraco-test-5.3.0.ebuild 926 BLAKE2B 4c47f2f786e8d58dfc2b3b330a09cdeda3a51918992629339fd6aeaaafa6aebcb7ec005b21c7701f3e5a3a8269b90f0096ff661b9895dc7254fd98b28dab1d7a SHA512 d17c83b8f4f47e4ab1a363fc0e98b14cd7a1215b26cf4984134449b5619703924c48592ebe48a2b9fe4c23823076ba9d5e029c96990ec454c047029ca5f1c3b4
EBUILD jaraco-test-5.4.0.ebuild 1018 BLAKE2B a8c0b93f17937761b74217f8b8e2557c37c7aa772fd5eb4adc69775b77cbf7265c0e864061603c2272c85887181461fd77d8cca9b9841ec68760ae2e8fa6ce5f SHA512 483ffe8dde530887ebbe891bd7f8ce9d9573cc9dee8bd7ca1901932dc493443e33a56bc3dc68bab4a29f04d5f813b41d290495a75bc1e1e3be7553fecd1d05bf
MISC metadata.xml 397 BLAKE2B 24c07f0efc966e9d4445968ba639a5476a24a0885051e4eab17075ea9b7b6369fe9ed919ccdc0b51a1e667c8d327428caac2196c2a3e087d8b36176e7b4b2c81 SHA512 4fce74bc524dc018611c219b86b87b7643fe5d133309a00dd5ade217895165f85cfbe26b686c79fc4dd8b1e016b07c83c25afa1c015fc240ffa0ac75e4c17159
diff --git a/dev-python/jaraco-test/jaraco-test-5.3.0.ebuild b/dev-python/jaraco-test/jaraco-test-5.3.0.ebuild
deleted file mode 100644
index 89eaf4b7d78a..000000000000
--- a/dev-python/jaraco-test/jaraco-test-5.3.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN=${PN/-/.}
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Testing support by jaraco"
-HOMEPAGE="
- https://github.com/jaraco/jaraco.test/
- https://pypi.org/project/jaraco.test/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/jaraco-context[${PYTHON_USEDEP}]
- dev-python/jaraco-functools[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- # while technically these tests are skipped when Internet is
- # not available (they test whether auto-skipping works), we don't
- # want any Internet access whenever possible
- local EPYTEST_DESELECT=(
- tests/test_http.py::test_needs_internet
- )
- epytest -m "not network"
-}