summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-stream
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-stream')
-rw-r--r--dev-python/jaraco-stream/Manifest2
-rw-r--r--dev-python/jaraco-stream/jaraco-stream-3.0.4.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/jaraco-stream/Manifest b/dev-python/jaraco-stream/Manifest
index 8a20e043e756..4e028ed04390 100644
--- a/dev-python/jaraco-stream/Manifest
+++ b/dev-python/jaraco-stream/Manifest
@@ -1,3 +1,5 @@
DIST jaraco.stream-3.0.3.tar.gz 8877 BLAKE2B 85289efe8e04e93cbceb0053f5025cad3d073deeb113806e25ca06fb88a9b082de6805305de85d1f17b77f61d2d0f4683b2b21f670102b03112b8f7a3fdafd91 SHA512 fe50c21b26e734c9c2d0b7cf8a1c8cc8bab80417adf073a4ae213ba4067aa33e2f6c8886aac996971d2f98aacd295d9999aa3ac7dba24dd952cc27d15bef22e2
+DIST jaraco_stream-3.0.4.tar.gz 10744 BLAKE2B dab536ba2927c361deb86500d2ac294351c18098f2f69b6f40f54a68ae438dad094ee5075ab6d1c73a7ccd6a05bf98edbbc5cf2441ecd68cef0c4129e94aa47f SHA512 f17647fd2dd1fcdc04d6ef62a95fe63d3f1c7e3acbc72600a414930c4b5d781b4148aff4bda94a47f6ece5c9666b976b321647e3f07c37ffb1ee2003bb075b07
EBUILD jaraco-stream-3.0.3-r1.ebuild 613 BLAKE2B 63e31352dd4fbd86523c42cedb2829bbb8609be3f822eaf2992dd45ba89bcb216fca248b4c14b8fc798ca2007ae36a77cbf1f0af601d1c582be75eb0ff8e8760 SHA512 9116b46045f65c8c015452d4083b6d5be69bdb6f649db96a29176458f36cb949ddb0e069499d483ef1a8210fa636898c87738174385cda5fba695b643afa9d33
+EBUILD jaraco-stream-3.0.4.ebuild 595 BLAKE2B ec754f2c735fbbf93b157ab41d0c2494fb13ac271fd02645d11e30b9fe438d80c454698eef099c93f7064601768c8d945f00c8496c50027c4ea3cd9dfbe07bb2 SHA512 1f86599f8dfbef042edf8edaceb1790f2f2483602307a898740bdead3a4926de244f302f351cc0589984b1843ecba3b01433ceb76fcd240e1d3e1f53b83523c5
MISC metadata.xml 622 BLAKE2B 244676932a2d41bd838b0300ebe5aa31e9cf38b4f18d503c33070b9dbc2243d1b87e12ed8c738cd3618d9dea0da0857a1d0e474cd019f41fada6063b9eb5b399 SHA512 f747157913e723fb0447e1cf265fb3391968a5301f03b475ad06abeddabbfbad218a70a26641770e44e8a042cf1ee8887eae719b125fea921163531dfa2430bd
diff --git a/dev-python/jaraco-stream/jaraco-stream-3.0.4.ebuild b/dev-python/jaraco-stream/jaraco-stream-3.0.4.ebuild
new file mode 100644
index 000000000000..f54c303f5af4
--- /dev/null
+++ b/dev-python/jaraco-stream/jaraco-stream-3.0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Routines for handling streaming data"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.stream/
+ https://pypi.org/project/jaraco.stream/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest