summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-packaging/jaraco-packaging-5.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-packaging/jaraco-packaging-5.1.1.ebuild')
-rw-r--r--dev-python/jaraco-packaging/jaraco-packaging-5.1.1.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/jaraco-packaging/jaraco-packaging-5.1.1.ebuild b/dev-python/jaraco-packaging/jaraco-packaging-5.1.1.ebuild
deleted file mode 100644
index df3a7c77515f..000000000000
--- a/dev-python/jaraco-packaging/jaraco-packaging-5.1.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Tools to supplement packaging Python releases"
-HOMEPAGE="https://github.com/jaraco/jaraco.packaging"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
-IUSE="doc test"
-
-RDEPEND="
- >=dev-python/six-1.4[${PYTHON_USEDEP}]
- dev-python/namespace-jaraco[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
- doc? (
- >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
- if use doc; then
- cd docs || die
- sphinx-build . _build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- # Skip one test which requires network access
- # Override pytest options to skip flake8
- PYTHONPATH=. py.test -v -k "not test_revived_distribution" \
- --override-ini="addopts=--doctest-modules" \
- || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- find "${ED}" -name '*.pth' -delete || die
-}