summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-logging/jaraco-logging-1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-logging/jaraco-logging-1.5.ebuild')
-rw-r--r--dev-python/jaraco-logging/jaraco-logging-1.5.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/jaraco-logging/jaraco-logging-1.5.ebuild b/dev-python/jaraco-logging/jaraco-logging-1.5.ebuild
deleted file mode 100644
index 77544c7b4847..000000000000
--- a/dev-python/jaraco-logging/jaraco-logging-1.5.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Additional facilities to supplement Python's stdlib logging module"
-HOMEPAGE="https://github.com/jaraco/jaraco.logging"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
- dev-python/tempora[${PYTHON_USEDEP}]
-"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_test() {
- PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
-}