summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-collections/jaraco-collections-4.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-collections/jaraco-collections-4.0.0.ebuild')
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-4.0.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/jaraco-collections-4.0.0.ebuild b/dev-python/jaraco-collections/jaraco-collections-4.0.0.ebuild
new file mode 100644
index 000000000000..90e5e642b752
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-4.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.collections/
+ https://pypi.org/project/jaraco.collections/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest