summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-collections/jaraco-collections-3.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-collections/jaraco-collections-3.4.0.ebuild')
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.4.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.4.0.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.4.0.ebuild
new file mode 100644
index 000000000000..477206eaacea
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-3.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs '>=dev-python/jaraco-packaging-3.2' \
+ '>=dev-python/rst-linker-1.9'
+distutils_enable_tests pytest